This week's book giveaway is in the Reactive Progamming forum.
We're giving away four copies of Reactive Streams in Java: Concurrency with RxJava, Reactor, and Akka Streams and have Adam Davis on-line!
See this thread for details.
Win a copy of Reactive Streams in Java: Concurrency with RxJava, Reactor, and Akka Streams this week in the Reactive Progamming forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Junilu Lacar
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • Tim Cooke
  • Devaka Cooray
Saloon Keepers:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Ganesh Patekar

Maven Build Error -- Not a v4.0.0 POM.

 
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am trying to determine how to resolve this build error. I beleive its looking for the (2.3/maven-resources-plugin-2.3.pom), but in my .m2/repository I only have 2.5 and 2.6. Is it just a matter of downloading the 2.3 version to this folder, or must I do something more elaborate?




Executing Maven:  -B -f /home/jenkins/jenkins/XXXXXXX/data/jobs/CI-WEB2-XXXXXX/workspace/cellci-java-XXXXXX/pom.xml install
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Building cellci-java-XXXXXX
[INFO]    task-segment: [install]
[INFO] ------------------------------------------------------------------------
Downloading: http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-resources-plugin/2.3/maven-resources-plugin-2.3.pom
1K downloaded  (maven-resources-plugin-2.3.pom)
[WARNING] *** CHECKSUM FAILED - Checksum failed on download: local = '559229297b3e5b1b8e92ed4f58d3cc033ed5c991'; remote = '<!DOCTYPE' - RETRYING
Downloading: http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-resources-plugin/2.3/maven-resources-plugin-2.3.pom
1K downloaded  (maven-resources-plugin-2.3.pom)
[WARNING] *** CHECKSUM FAILED - Checksum failed on download: local = '559229297b3e5b1b8e92ed4f58d3cc033ed5c991'; remote = '<!DOCTYPE' - IGNORING
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error building POM (may not be this project's POM).


Project ID: org.apache.maven.plugins:maven-resources-plugin
POM Location: /home/jenkins/.m2/repository/org/apache/maven/plugins/maven-resources-plugin/2.3/maven-resources-plugin-2.3.pom

Reason: Not a v4.0.0 POM. for project org.apache.maven.plugins:maven-resources-plugin at /home/jenkins/.m2/repository/org/apache/maven/plugins/maven-resources-plugin/2.3/maven-resources-plugin-2.3.pom
 
Saloon Keeper
Posts: 10652
227
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The problem is likely caused because of the checksum issues during downloading. You need to solve those first. Try Googling for "maven checksum failed".
 
Joffrey Williams
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for the assist.
 
Why should I lose weight? They make bigger overalls. And they sure don't make overalls for tiny ads:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!