I would suggest you should move most of that code out of the
main method. I think you should have a result class, which incorporates the grades, calculates the results, etc.
I would also suggest you use else if rather than straight if statements.
Also consider the use of operators. The >= and <= operators are harder to understand that < and >. Also,
100 > average is much more difficult to understand than
average < 100. You can make if statements really easy to understand or really difficult to understand by the operators you use.
Why 79.5 (etc)? What will you get for a mark of 79.6?