• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Devaka Cooray
  • Ron McLeod
  • Jeanne Boyarsky
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Carey Brown
  • Tim Holloway
Bartenders:
  • Martijn Verburg
  • Frits Walraven
  • Himai Minh

Split dev. directory - missing web.xml?

 
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Good morning,

I have set up a split development structure for developing a simple weblogic app. When I run appc, I receive the following error:

[weblogic.utils.compiler.ToolFailureException: [J2EE:160121]Errors encountered while compiling module 'C:\project\myApp\build\myAppEar':

Required file WEB-INF/web.xml not found
- with nested exception:
[
Required file WEB-INF/web.xml not found
]]




Here is the structure below:

C:\PROJECT\myApp
+---build
| \---myAppEar
| +---APP-INF
| | \---classes
| | \---com
| | \---my common compiled classes here.....
| \---myAppWebApp
| \---WEB-INF
| \---classes
\---src
\---myAppEar
+---APP-INF
| +---classes
| \---lib
+---common
| \---com
| \---my common sources here.....
+---META-INF
+---myAppWebApp
+---css
+---images
+---js
\---WEB-INF
+---classes
\---src

Contents of C:\project\myApp\build\myAppEar\.beabuild.txt:

#
#Mon Jan 31 08:48:03 EST 2005
bea.srcdir=C\:/project/myApp/src/myAppEar




I do have a web.xml file in C:\project\myApp\src\myAppEar\myAppWebApp\WEB-INF. Any ideas?

Best regards,

Joshua
 
drifter
Posts: 1364
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
How are you running appc. From your build.xml? Did you "use the weblogic.BuildXMLGen utility to create a basic build.xml file"?

Not having worked with a split directory environment I'm not familiar with how this would be done.

Is the "target" of the appc comand the source or build directory or ?

I was also wondering what version of wls you are using.
[ February 04, 2005: Message edited by: Carol Enderlin ]
 
My first bit of advice is that if you are going to be a mime, you shouldn't talk. Even the tiny ad is nodding:
the value of filler advertising in 2021
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic