• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Tim Cooke
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • paul wheaton
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Ron McLeod
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Tim Holloway
  • Carey Brown
  • salvin francis

install jforum on WildFly 8.1.0.Final - install module not found

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am trying to install jforum on WildFly 8.1.0.Final "Kenny" on Ubuntu x86_64.
I am trying to do an installation according to https://sourceforge.net/p/jforum2/wiki2/ManualInstallation/ with some modifications.
(I cannot use installation via GUI)

My steps:
1. Download jforum-2.4.1.war
2. Unpack it to wildfly's wildfly-8.1.0.Final/standalone/deployments/jforum.war directory (directory, not packed file)
3. Remove WEB-INF/lib/jboss-*.jar (3 jars removed)
4. Add writing permission to directories
upload
tmp
images
WEB-INF/config
WEB-INF/jforumLuceneIndex
5. I have properly configured postgresql database. I use net.jforum.DataSourceConnection. Database settings according to ManualInstallation page listed above.
6. I created jforum-custom.conf with installed=true inside.
7. I Removed the line "install = net.jforum.view.install.InstallAction" from the file WEB-INF/config/modulesMapping.properties
8. I created the file wildfly-8.1.0.Final/standalone/deployments/jforum.war.dodeploy
9. I opened http://localhost:8080/jforum
I was redirected to http://localhost:8080/jforum/install.jsp
And I see message on that page :

An error has occurred.
For detailed error information, please see the HTML source code, and contact the forum Administrator.
install module not found.
Add "install=net.jforum.view.install.InstallAction" to modulesMapping.properties if you want to reinstall JForum.

In HTML code:
<!-- BEGIN ERROR STACK TRACE
Only moderators can view stack trace.
END ERROR STACK TRACE-->

Any advice?

My versions:
openjdk version "1.8.0_121"
OpenJDK Runtime Environment (build 1.8.0_121-8u121-b13-0ubuntu1.16.04.2-b13)
OpenJDK 64-Bit Server VM (build 25.121-b13, mixed mode)


 
Talk sense to a fool and he calls you foolish. -Euripides A foolish tiny ad:
professionally read, modify and write PDF files from Java
https://products.aspose.com/pdf/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!