• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Rob Spoor
  • Devaka Cooray
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
  • Tim Holloway
Bartenders:
  • Jj Roberts
  • Al Hobbs
  • Piet Souris

Missing artifact javax.servlet: javax.servlet-api:jar:3.0

 
Ranch Hand
Posts: 834
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Dear expert,

Today,  I realised that I would need to type in the dependencies when I use Maven.

However, I do not understand the error message :

Missing artifat javax.servlet: javax.servlet-api:jar:3.0

I have Apache Tomcat 7.0 in which javax.servlet-api is included but I can't see 3.0.

I am basing the 3.0 based on the line below which is part of the web.xml
<web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://java.sun.com/xml/ns/javaee" xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_3_0.xsd" version="3.0">

Hence, I hope someone can give me a clue how to get rid of the error or is there anything I should rectify in setting my pom file ?

servlet-mapping-question.jpg
[Thumbnail for servlet-mapping-question.jpg]
 
Saloon Keeper
Posts: 7165
165
  • Likes 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Looking at http://mvnrepository.com/artifact/javax.servlet/javax.servlet-api, it would seem that 3.0.1 is available, but not 3.0.
 
reply
    Bookmark Topic Watch Topic
  • New Topic