Answer to question 9 on page 220 (Review Questions for chapter 4 "Methods and Encapsulation") state that C is correct answer
Athough Table 4.5 on page 206 says that "The method name MUST have a prefix of set/get/is, followed by the first letter of the property in uppercase, FOLLOWED BY THE REST OF THE PROPERTY NAME.", which means that for property named numberWings we must use "getNumberWings", not "getNumWings" methodName.
Is there errata on page 206 (on table) or page 343 (on aswer) ?
Thanks for answers!
posted 2 years ago
Text under the table on page 206 also says "Only the method name and property name have naming conventions here."