Win a copy of JDBC Workbook this week in the JDBC and Relational Databases forum
or A Day in Code in the A Day in Code forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Sheriffs:
  • Ron McLeod
  • Devaka Cooray
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Frits Walraven
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • salvin francis
  • fred rosenberger

Error when using <html xmlns:th="http://thymeleaf.org">

 
Ranch Hand
Posts: 78
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I am following a java video tutorial. One part is to set up the html registration page.

My problem is that i keep getting this error on line 2 in my Spring Tool Suite IDE when creating the "register.html" page. Also line 31 "</form> gives a warning. See attachment for Errors.

Any idea what i am missing?





error.PNG
[Thumbnail for error.PNG]"/>
Error
 
Sheriff
Posts: 3102
459
Android Eclipse IDE TypeScript Redhat MicroProfile Quarkus Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
In your image, you point to a red circle and a yellow triangle in the IDE, but don't mention what the associated with error and warning messages are.
 
Ron McLeod
Sheriff
Posts: 3102
459
Android Eclipse IDE TypeScript Redhat MicroProfile Quarkus Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is the namespace URI correct?  Should it be http://www.thymeleaf.org rather than http://thymeleaf.org?
 
Arend van der Kolk
Ranch Hand
Posts: 78
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Ron,

you are right, it doesn't actually generate an error message but the red symbol normally indicates a compile time error in the IDE.

I just cut and paste back the entire code block and the red mark at the top and the warning symbol on the bottom are now gone.

just an IDE bug i guess.

thank you for your response.

Arend
 
I like tacos! And this tiny ad:
Devious Experiments for a Truly Passive Greenhouse!
https://www.kickstarter.com/projects/paulwheaton/greenhouse-1
    Bookmark Topic Watch Topic
  • New Topic