• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Junilu Lacar
Sheriffs:
  • Rob Spoor
  • Liutauras Vilda
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Piet Souris
  • Tim Holloway
  • Jj Roberts
  • Stephan van Hulst
Bartenders:
  • Himai Minh
  • Carey Brown
  • Frits Walraven

Context path stripped from deployed app

 
Greenhorn
Posts: 20
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I'm getting a really strange problem in WebLogic 8.1 SP 3 on RedHat Enterprise Linux. I built and deployed my app as a war file using the WebLogic console. The console reports "success"

but when I went to the "testing" tab the URI of the app is given as:

http://localhost:7001//

Note the two slashes and no context root.

When I try to visit the app in a browser I get a 404 error.

Can you offer any troubleshooting suggestions?

I deployed the same war file on a Tomcat 5.5.9 server and it works fine, so I know the code is valid.

I tried adding a <context-root> element to weblogic.xml, but the produced the same result.

Thanks,

JM
 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic