• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

problem in upgrading wl6 to wl 8.1

 
Ranch Hand
Posts: 107
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi guys,
I am facing problem in upgrading the weblogic 6 to weblogic 8.1. I am running my application running on linux. the steps i followed are:

1. created link to point where my application (file structure) located at WL_HOME/config/<mydomain> this folder points to the actual application. believe me guys this is not a problem i guess.

2. updated my setEnv.sh and startWeblogic.sh scripts and pointed the weblogic.jar etc correctly.

3. made slight changes in weblogic.xml file these changes are:
removed the old entry and added these lines:
<Security Name="mydomain" Realm="mysecurity"/>
<Realm Name="mysecurity" FileRealm="myrealm"/>
<FileRealm Name="myrealm"/>

4. tried to start the WL Server, resulting these eorrors:

***************************************************************************
The WebLogic Server did not start up properly.
Exception raised: 'weblogic.management.configuration.ConfigurationException: The MBean wlsadmin:Name=wlsadmin,Type=Security had an unresolved reference for the attribute Realm the mbean wl_default_realm'
Reason: weblogic.management.configuration.ConfigurationException: The MBean wlsadmin:Name=wlsadmin,Type=Security had an unresolved reference for the attribute Realm to the mbean_default_realm
***************************************************************************



does anybody has any idea?
 
Ranch Hand
Posts: 2713
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Did you create a new domain for WLS 8.1? I wouldn't even consider modifying an existing WLS 6.1 domain and expect it to work...
 
Ranch Hand
Posts: 79
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
The best way is to create a new domain in weblogic81 and move all the codes from weblogic6 to version 8.
 
reply
    Bookmark Topic Watch Topic
  • New Topic