• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

Tomcat 9 not working with ssl

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!
I try to configure tomcat 9 with ssl but I cannot find the way to make it work. I think i've followed the tutorial on their website (https://tomcat.apache.org/tomcat-9.0-doc/ssl-howto.html), but I got this message on chrome :

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

Here what I did for the autosigned certificate :

sudo ./keytool -genkey -alias tomcat -keyalg RSA -keystore monKeystore -keypass changeit -storepass changeit
sudo ./keytool -export -alias tomcat -keystore monKeystore -storepass changeit -file monKeystore.cer
sudo ./keytool -import -trustcacerts -file monKeystore.cer -alias tomcat -keystore $JAVA_HOME/jre/lib/security/cacerts

And here what I got in tomcat server.xml :

<Connector port="8443" protocol="org.apache.coyote.http11.Http11NioProtocol"
       maxThreads="150" SSLEnabled="true" scheme="https" secure="true"
       keystoreFile="/usr/lib/jvm/java-8-oracle/bin/monKeystore" keystorePass="changeit"
       clientAuth="false" sslProtocol="TLS" />

When I start tomcat I got no error in logs, but it doesn't work anyway. Any idea? Thanks

 
Saloon Keeper
Posts: 22273
151
Android Eclipse IDE Tomcat Server Redhat Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Have you tried this? https://www.deskdecode.com/err_ssl_version_or_cipher_mismatch/
 
lempkin ebowyn
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Actually I've tried this and this is working now : https://stackoverflow.com/questions/30124002/tomcat-7-ssl-not-working-err-ssl-version-or-cipher-mismatch
Thanks =)
 
Life just hasn't been the same since the volcano erupted and now the air is full of tiny ads.
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
    Bookmark Topic Watch Topic
  • New Topic