Win a copy of Event Streams in Action this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Knute Snortum
  • Rob Spoor
Saloon Keepers:
  • Tim Moores
  • Ron McLeod
  • Piet Souris
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Frits Walraven
  • Ganesh Patekar

Spring Oauth not authenticating

 
Rancher
Posts: 471
6
IntelliJ IDE Spring Fedora
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I got basic authentication to work with  userdetails, and userdetailsservice,
but my ultimate goal was to set up oauth2.
When I try to access my rest api with post man I get this response.
]

My server debug:



It looks like it's trying to do basic authentication for the client id that I put in the request.
I know the PasswordEncoder problem has to do with a wrong password format
but while I was debugging it never used my userdetailsservice so it wasn't even looking at the database.

my configs:




The client name is my-client-with-secret, so the matching secret is "secret."
I ran a spring demo app with a similar request and it worked fine with even less configuration.
What could be the problem?

Thanks!
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!