This week's book giveaway is in the General Computing forum.
We're giving away four copies of Emmy in the Key of Code and have Aimee Lucido on-line!
See this thread for details.
Win a copy of Emmy in the Key of Code this week in the General Computing forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Junilu Lacar
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • Devaka Cooray
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Ron McLeod
  • Carey Brown
Bartenders:
  • Paweł Baczyński
  • Piet Souris
  • Vijitha Kumara

problem with URL of the application but works fine with Localhost:port

 
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

My application is struts based running in tomcat. Recently i migrated the application from tomcat to weblogic 8.1 SP4.

In weblogic, application is working fine with localhost:7000

But if I try to access the application through test.mydomain.com(Actual URL)
then application throws 403 error.


What more I found that when there is any forward in the action class, application repeats the previous URL(Not picking the forward path)

For ex
http://test.mydomain.com/test/logon.do
method being is added to it and URL becomes

http://test.mydomain.com/test/logon.do?m=begin

Control goes inside begin method and find the forward say success. Control goes to struts-config and then forward path is
/myAction.do?m=begin

At this point, application still forward the request to previous link
http://test.mydomain.com/test/logon.do?m=begin

and goes in loop.

The whole process works fine with
http://localhost:7000/test/logon.do

I have done all necessary configuration changes to the wlforward.ini and iisproxy.ini.

have added iispforward.dll into filter of IIS.

Still facing problem.


Please suggest me a solution.
Please let me know if more information is required to understand the issue.

help will be appriciated.

Thanks in advance.


Regards
 
Whose rules are you playing by? This tiny ad doesn't respect those rules:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!