This week's giveaway is in the Spring forum.
We're giving away four copies of Microservices Testing (Live Project) and have Chris Love & Andres Sacco on-line!
See this thread for details.
Win a copy of Microservices Testing (Live Project) this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

Is weblogic 8.1 compatible with JDK 1.5?

 
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi All,

We have a requirement to update our server with JDK 1.5. We also have weblogic 8.1 running on that server. Would this activity come up with any compatibility issue?

Thanks in advance.

Regards
Saurabh
 
Ranch Hand
Posts: 1683
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
WebLogic Server 8.1 supports JDK 1.4. You will need to migrate to at least WebLogic Server 9.0 in order to run JDK 1.5.
 
SaurabhSri Sri
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Roger,

Thanks for your replay. Migrating from weblogic 8.1 to weblogic 9.0 might be a complex activity for us, as so many application are deployed on weblogic 8.1.

Do we crate a domain which can use anyway jdk 1.5?
 
Roger Chung-Wee
Ranch Hand
Posts: 1683
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
You can have multiple JDKs installed on a server. Why would the presence of JDK 1.5 affect your WebLogic Server 8.1?
 
Ranch Hand
Posts: 257
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I bet your weblogic8.1 server can not run on java 1.5.
 
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
This is a business process , first try to migrate the projects deployed in 8.2 to 9.2 , it doesnt have so much complexity because server JDK5.0 have can accepts 1.4 too,but 1.5 in weblogic 8.1 is may not be possible
 
Java Cowboy
Posts: 16084
88
Android Scala IntelliJ IDE Spring Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
There's no need to guess or bet if it will work or not.

Look at the documentation from BEA, especially this: Supported Configurations for WebLogic Platform 8.1.

WLS 8.1 is only guaranteed by BEA to work on the operating systems and JVM versions listed in the tables on that page. It might work on a newer JVM or it might not - either way, it's not guaranteed by BEA so it is not recommended to try it in a production environment.
 
Amit M Tank
Ranch Hand
Posts: 257
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Just so you all know. I have tried using JDK 1.5 for weblogic8.1 and it gives some Exception like AssertionException when I start weblogic.
 
reply
    Bookmark Topic Watch Topic
  • New Topic