• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Perm size for managed servers

 
Ranch Hand
Posts: 3852
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have a weblogic domain with one admin server and two managed server. I was getting Permgen - OutOfMemoryException for both admin server and managed servers.

I updated setDomainEnv.sh file and increased Perm size and it seems that it worked for admin server. But not for managed server.

How do I update Perm size for managed server?

Thanks.
 
Ranch Hand
Posts: 977
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

are you using Nodemanager? If you're using nodemanager you can configure JVM parameter using Administration console Go to Server>${your_server_name}>Configuration>Server Start and than place your arguments on the Arguments field, this will be used by nodemanager when it starts your server.

If you're not using nodemanager you can edit startManagedWeblogic.sh script under ${domain_name}/bin and set USER_MEM_ARGS variable with desired JVM parameters.

This is the script used to start managed servers on a domain.

regards.
 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic