Win a copy of TensorFlow 2.0 in Action this week in the Artificial Intelligence and Machine Learning forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Paul Clapham
  • Bear Bibeault
  • Jeanne Boyarsky
Sheriffs:
  • Ron McLeod
  • Tim Cooke
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Jj Roberts
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • salvin francis
  • Scott Selikoff
  • fred rosenberger

http server will not start

 
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am working with websphere Advanced edition v3.5 and IBM HTTP Server on AIX. the problem I am facing is that - though the websphere Application server is starting up and running fine, the HTTP Server cannot be started. If the LoadModule(mod_ibm_app_server.so), AddModule(mod_app_server.c), Alias(bootstrap.properties) lines are commented out in the httpd.conf file the http server starts up. Also, if i try to start the http server with the above mentioned lines uncommented, I get a core-dumped error.
Any suggestions/ reasons for this ?
Thanks.
 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
We have the same problem. IBM HTTPServer 1.3.12.3 will not start unless I comment out the referenced to mod_ibm_app_server.so
WAS Advanced 3.5.4, UDB 6.1.0.45 (fp8)
Any ideas?? I read somewhere that the June 2001 issue of WebSphere Advisor had an article on this topic but I cannot track it down.. Does anyone have that around that they could fax??
Thanks,
Pat.
 
OSullivan Pat
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
After much searching we tracked this down:
"AIX fixpack IY19277 can fix this problem"
It appears to occur on multi-processor machines. On a new 270 with AIX 4.3.3.50, I only had to apply the bos updates using smit, rebooted and IHS came up with the WebSphere hooks.
I hope this helps anyone else with this problem.
You can get the details from: http://techsupport.services.ibm.com/cgi-bin/support/rs6000.support/fdget?fixdb=aix4&srchtype=apar&hits-menu=IY19277+-+%28AIXV43+only%29+UNREGISTER+LIBODM+FORK+HANDLER+WHEN+UNLOADIN G&aix_level=AIX+4.3.3&select_site=us&select_lang=ALL
Pat.
[This message has been edited by OSullivan Pat (edited September 17, 2001).]
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Pat, I've taken a look at the IBM website which indicates that this patch is to be applied for WebSphere V 4.0 and 4.01 - can you confirm that is what you are running? This problem seems to match one that we are having but our setup is WAS 3.5.4 and I don't want to apply this patch if it's not relevant to the WAS 3.5.4 environment. One reason is because this is a fairly low-level patch that modifies libc and the pthreads base operating system runtime environment, so there's a strong possibility that applying it will require a reboot for it to be fully applied correctly.

Originally posted by OSullivan Pat:
After much searching we tracked this down:
"AIX fixpack IY19277 can fix this problem"
It appears to occur on multi-processor machines. On a new 270 with AIX 4.3.3.50, I only had to apply the bos updates using smit, rebooted and IHS came up with the WebSphere hooks.
I hope this helps anyone else with this problem.
You can get the details from: http://techsupport.services.ibm.com/cgi-bin/support/rs6000.support/fdget?fixdb=aix4&srchtype=apar&hits-menu=IY19277+-+%28AIXV43+only%29+UNREGISTER+LIBODM+FORK+HANDLER+WHEN+UN LOADIN G&aix_level=AIX+4.3.3&select_site=us&select_lang=ALL
Pat.
[This message has been edited by OSullivan Pat (edited September 17, 2001).]


 
She still doesn't approve of my superhero lifestyle. Or this shameless plug:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
reply
    Bookmark Topic Watch Topic
  • New Topic