• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

How to run a servlet in Websphere Test Environment?

 
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi there,
I know this question may sound too basic for some people, but I got stuck when I tried to run a very simple servlet in WebSphere Test Environment (WTE).
In the Workbench of VisualAge for Java (VAJava), I created a very simple servlet in the default package of WTE. There are already 2 servlets there - HelloWorldServlet and TestServlet. They came with installation and they work fine.
However, when I ran my servlet, I got this error message:

The source code of my servlet is:

The computer is an NT 4.0 workstation. I only had VAJava Enterprise Edition v3.5 and its WTE running on it. I turned off WebSphere Application Server v3.5 and Personal Web Server 4.0.
Since the 2 original servlets in the default package work fine, I thought I might have a configuration issue. Do I need to modify any xml file to test my servlets in WTE? Or did I miss something else?
Thank you in advance!
Tony
 
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Right click on the localhost, choose properties and the publishing tab.
Here make sure that the radio button checked is the one next to "publish using file system: and on the drop down select WINNT.
Go doen to the "Webapp web path:" and make sure that this is blank.
Go to "publishing target:" and click on the "targets" button. For html and servlets, put it the path where your localhost is located. Because by default Websphere publishes under a "publish" folder in studio.
I hope that this helps.
 
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Make your class public and it will work
 
Run away! Run away! Here, take this tiny ad with you:
a bit of art, as a gift, the permaculture playing cards
https://gardener-gift.com
reply
    Bookmark Topic Watch Topic
  • New Topic