• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Knute Snortum
  • Paul Clapham
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Ron McLeod
  • Piet Souris
  • Frits Walraven
Bartenders:
  • Ganesh Patekar
  • Tim Holloway
  • salvin francis

connection to mysql problem  RSS feed

 
Greenhorn
Posts: 19
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi

I tried to make a ping from glassfish to mysql. here is the error :
Cannot open file:F:\glassfish-5.0\glassfish5\glassfish\domains\domain1/config/keystore.jks [Keystore was tampered with, or password was incorrect]

I changed master password,tried different resource type,set allow permission to all users but without result.Ive access to de same database from tomcat.
I dont create another domain in glassfish yet(using de defualt one,domain1)

I really searched every aspect of dis problem,still got an error >.<


my glassfish ver is 5.0
- Resource Type:javax.sql.DataSource
- Datasource Classname:com.mysql.cj.jdbc.MysqlDataSource

mysql ver is 8.0.13

I spend two days for dis ,where is my problem?

Edit:

I dont have dis problem on mysql driver 5.1
so I think my problem is related to new packages came from in mysql driver 8.

Update:
porblem solved.
add useSSL property and set to false(default is true).

 
Good heavens! What have you done! Here, try to fix it with this tiny ad:
how do I do my own kindle-like thing - without amazon
https://coderanch.com/t/711421/engineering/kindle-amazon
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!