Win a copy of 97 Things Every Java Programmer Should Know this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Sheriffs:
  • Ron McLeod
  • Devaka Cooray
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Frits Walraven
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • salvin francis
  • fred rosenberger

JAX-RS 2.0 requires Java 1.6 or newer

 
Sheriff
Posts: 3113
459
Android Eclipse IDE TypeScript Redhat MicroProfile Quarkus Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am using the latest version of Eclipse (2019-03 4.11.0) with the Maven m2e plug-in on Windows 10 (and still new to Maven).

Yesterday things were working fine, but today, after restarting Eclipse, I am seeing an error which seems to indicate that my version of Java is lower than what is required, and I can't figure-out why.  I have seen this kind of error when the Java version is not specified in the pom.xml file (seems like Maven defaults to Java 1.5), but in this case it has been specified.  I believe that the Eclipse settings below are being configured by the Maven plug-in.

Any ideas on what I can look at to resolve this problem?








 
Ron McLeod
Sheriff
Posts: 3113
459
Android Eclipse IDE TypeScript Redhat MicroProfile Quarkus Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Seems like this might have been a problem with Eclipse and not Maven.  

I exported and then imported the project back in to the Eclipse workspace and everything is fine again.


Update: The problem returned after updating my project based on the pom.xml, so still broken.
 
Ron McLeod
Sheriff
Posts: 3113
459
Android Eclipse IDE TypeScript Redhat MicroProfile Quarkus Java Linux
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I found my problem.  I found that the web.xml file that I had updated to reference schema version 3.1, somehow got put back to version 2.3.


Since I am not using web.xml anyway, I just removed it and added the following plug-in to my pom.xml so that there is no dependency on the web.xml file:
 
Ew. You guys are ugly with a capital UG. Here, maybe this tiny ad can help:
Devious Experiments for a Truly Passive Greenhouse!
https://www.kickstarter.com/projects/paulwheaton/greenhouse-1
    Bookmark Topic Watch Topic
  • New Topic