Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
JavaRanch.com/granny.jsp
Win a copy of Event Streams in Action this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Knute Snortum
  • Rob Spoor
Saloon Keepers:
  • Tim Moores
  • Ron McLeod
  • Piet Souris
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Frits Walraven
  • Ganesh Patekar

Illegal use of 1PC resource in transaction

 
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi there.
Can anybody help with the following exception : Illegal use of 1PC resource in transaction.
Are running IBM WAS 4.0.3. No eFixes have been applied. Have a stateless session bean(not supported) calling CMP beans(requires new). Seems to work fine when doing finders, but throws exception when calling create on CMP beans.
Thanx
Kevin
 
Ranch Hand
Posts: 906
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
"Illegal use of 1PC resource in transaction" should occur when you try to establish a transaction over 2 (or more) databases without using a XA driver.
But it can also occur due to WebSphere bugs :
Check this link
HTH
 
Kevin Kotze
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Originally posted by Bill Bailey:
"Illegal use of 1PC resource in transaction" should occur when you try to establish a transaction over 2 (or more) databases without using a XA driver.
But it can also occur due to WebSphere bugs :
Check this link
HTH


Thanx Bill.
Only using one database. But am using a unique id generator in the create method on the CMP beans that gets the next sequence number from the database. Obviously this unique id generator also looks up the datasource, and from the link you posted it is clear that this datasource lookup is causing the problem. But problem is that the IBM link only provides a fix for WAS 4.0.1 and cant be applied to the WAS 4.0.3 version that is running. Do you know of any fixes for this version of WAS that will sort out the problem?
Thanx
Kevin
 
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi,
am also looking for this e-fix for V4.0.3 and above.pls do send in the link if anyone happens to find it.
bye and cheers!!!
kabs
 
Consider Paul's rocket mass heater.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!