Win a copy of Rust Web Development this week in the Other Languages forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Junilu Lacar
  • Rob Spoor
  • Paul Clapham
Saloon Keepers:
  • Tim Holloway
  • Tim Moores
  • Jesse Silverman
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Piet Souris
  • Frits Walraven

Please Help Kyle. Problem with ejb deploy using ant for websphere

 
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi
I have the following code (I am unable to print the Gthan Lthan signs so the xml is printed without the opening and closing tags)

However when i run ant i get the following exceptionbuildEJB:
[echo] The build.class is C:\PVCS\Frameworks\xxxTestEJB\src
[echo] The testDeployedEJBDir is C:\PVCS\Frameworks\xxxTestEJB\de
ployedJar
[echo] The properties.folder is C:\Program Files\IBM\WebSphere Studio\works
pace\xxxEJB\ejbModule\META-INF
[ejbjar] building xxxEJB.jar with 14 files
BUILD FAILED
file:c:/ant/WebSphere4Build.xml:191: Exception while calling ejbdeploy. Details:
java.lang.NullPointerException
.
The vanilla generic ejb jar with the class files are generated but no deployment takes place.
My classpath is as follows
[echo] Classpath is now C:\PVCS\Frameworks\libraries\JUNIT\lib\junit.jar;C:
\Program Files\IBM\WebSphere Studio\runtimes\aes_v4\java\jre\lib\rt.jar;C:\Progr
am Files\IBM\WebSphere Studio\runtimes\aes_v4\lib\j2ee.jar;C:\Program Files\IBM\
WebSphere Studio\runtimes\aes_v4\lib\ujc.jar;C:\Program Files\IBM\WebSphere Stud
io\runtimes\aes_v4\lib\ejbcontainer.jar;C:\Program Files\IBM\WebSphere Studio\ru
ntimes\aes_v4\lib\cm.jar;
can anyone tell me how to detect the problem I am unable to even print a stack trace. Does anyone know how to turn it on?
[ November 15, 2002: Message edited by: Kaustuva Mukherjee ]
[ November 15, 2002: Message edited by: Kaustuva Mukherjee ]
reply
    Bookmark Topic Watch Topic
  • New Topic