Win a copy of Modern JavaScript for the Impatient this week in the Server-Side JavaScript and NodeJS forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

wsad debugging - always restarts the server on resource modification

 
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
We are using WSAD to develop a web application (NO EJBS)
The problem I am having is that on resource modification WSAD restarts the server (in Debug mode).
When i running in debug mode and I make a change to a java file and save it this is what happens.
If the class has been loaded
WAS under WSAD tries to restart the server. It tries to stop the running server and fails. If we go kill the server instance and start it again alls fine.
If the class has not been loaded
WAS works just fine.
My ibm-web-ext.xmi is
<webappext:WebAppExtension xmi:version="2.0" xmlns:xmi="http://www.omg.org/XMI"; xmlns:webappext="webappext.xmi" xmlns:webapplication="webapplication.xmi" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"; xmi:id="WebAppExtension_1"<br /> reloadInterval="3"<br /> reloadingEnabled="true"<br /> defaultErrorPage="error.jsp"<br /> additionalClassPath=""<br /> fileServingEnabled="true"<br /> directoryBrowsingEnabled="false"<br /> serveServletsByClassnameEnabled="true"<br /> preCompileJSPs="true">
<webApp href="WEB-INF/web.xml#WebApp"/>
<jspAttributes xmi:id="JSPAttribute_1" name="keepgenerated" value="true"/>
</webappext:WebAppExtension>
Under windows --> preferences --> server I have
Publishing Method as "Smart publish"
and all the other values as default.
How do I get the WSAD Websphere test enviornment not to restart on every change.
Raghu
 
Ranch Hand
Posts: 98
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you use the Deployment descriptor for that web app, on the extensions tab you should be able to disable the Reloading.
That file you showed in your post has true for the reloading setting, the editor will change that to False and it should not do that.
I though had trouble getting JSPs to recompile after being changed when I turned that off, but that could be another problem.
 
raghuveer rao
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sorry I did not understand ..........which extensions tab.
So you are saying the reload should be set to false.
<webappext:WebAppExtension xmi:version="2.0" xmlns:xmi="http://www.omg.org/XMI"; xmlns:webappext="webappext.xmi" xmlns:webapplication="webapplication.xmi" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"; xmi:id="WebAppExtension_1"<br /> reloadInterval="3"<br /> reloadingEnabled="true"<br /> defaultErrorPage="error.jsp"<br /> additionalClassPath=""<br /> fileServingEnabled="true"<br /> directoryBrowsingEnabled="false"<br /> serveServletsByClassnameEnabled="true"<br /> preCompileJSPs="true">
<webApp href="WEB-INF/web.xml#WebApp"/>
<jspAttributes xmi:id="JSPAttribute_1" name="keepgenerated" value="true"/>
</webappext:WebAppExtension>
Thanks.
 
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What are your defaults in Server Preferences? One of the options is "Automatically restart servers when necessary". I believe if this is option is selected you'll get this behavior. The "reloadingEnabled" extension option is for reloading updated files in the Web application and has should have nothing to do with the server.
[ May 22, 2003: Message edited by: Sitster ]
 
raghuveer rao
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Automattically restart server when required is not checked.
I want WAS to reload just the changed class in debug mode. I dont want it to stop the server and relaod all the classes and servlets.
Raghu
 
Paul Duer
Ranch Hand
Posts: 98
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes, if you don't want the entire web application to be reloaded on resource change, then you need to change that option to false.
I usally make changes in those settings by double clicking on the WEB.INF file, that loads websphere's built in web deployment descriptor editor. Here you'll find all of the parts of a deployment descriptor listed in menus and checkboxes. You can make changes and WSAD will update the XML of the WEB.INF file accordingly.
As for the class only reload, if you figure out how to do that, I would like to know. So far it seems to be all or nothing. You can either turn on reloading of the whole thing, or turn it off and restart the web app at your will.
 
The two armies met. But instead of battle, they decided to eat some pie and contemplate this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
    Bookmark Topic Watch Topic
  • New Topic