This week's giveaway is in the Cloud/Virtualization forum.
We're giving away four copies of Secure Financial Transactions with Ansible, Terraform, and OpenSCAP and have Lucian Maly on-line!
See this thread for details.
Win a copy of Secure Financial Transactions with Ansible, Terraform, and OpenSCAP this week in the Cloud/Virtualization forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Rob Spoor
  • Henry Wong
  • Liutauras Vilda
Saloon Keepers:
  • Tim Moores
  • Carey Brown
  • Stephan van Hulst
  • Tim Holloway
  • Piet Souris
Bartenders:
  • Frits Walraven
  • Himai Minh
  • Jj Roberts

Howdy this is technical a pass-thru on LAN to Server (see detail) LAN-2-LAN

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello here is what I have

Server (LAN IP for Apache is 172.16.0.5)
* $ ifconfig
  shows eth0:
  eth0 validated @ 172.16.0.5

Firewall (LAN IP for Linux Firewall is 192.168.0.10)
* $ ifconfig
 shows enp0s0:
 enp0s0 validated @ 192.168.0.10

Another PC on LAN for Testing

I have tested this and got this far. I am familiar with IPTABLES but a greenhorn haha. If I log into 172.16.0.5 and try localhost in browser it works.

When I try another PC on the lan it trys to get to 172.16.0.5 but fails. The browser says site unavailable or too busy.

To test

If I log into 192.168.0.10 and type 172.16.0.5 it sees apache no problem - works.

I run $ tcpdump -i on both eth0: and enp0s0: there is data on enp0s0: when I try to access from the testing PC. The one that the browser says unavailable. But I see tcp traffic on the 192.168.0.10 machine (enp0s0) but nothing on eth0: So I know I have right conditions for seeing my tests but can't break thru to eth0: from my test pc. As you can see I am trying to figure out if I need something else. Not sure because it appears to be a forwarding issue.

I don't know how to test anymore. Thank you if anybody knows.

 
Saloon Keeper
Posts: 23441
159
Android Eclipse IDE Tomcat Server Redhat Java Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Welcome to the Ranch, Jeff!

This looks more like a general Linux networking issue than Tomcat. I'll see if I can link over there.

If I'm reading this correctly, you have 2 LAN segments, one for the server and one for the desktops. The server is on the 172 segment, and the desktops are on the 192.168 segment.

Where I get confused is the "firewall". I'm guessing that it's supposed to link the 172 and 192.168 subnets. Meaning that it's actually a router machine, since all well-configured machines have their own firewalls these days.

To link the 2 LAN segments properly, a couple of things have to be done:

1. You have to have IPV4 forwarding turned on on the routing machine.

2. You have to have a NIC configured for each connected subnet on the routing machine.

3. The NICs do have to have appropriate firewall configurations (iptables or firewalld) settings.

and last, but not least:

4. The IP routing has to be set up so that the 192.168 subnet can route to the 172 subnet and vice versa. That's done by the ip route command, but is normally stored as a permanent system setting in a format and location determined by which flavor of whatever OS the router machine is running.

 
Jeff Young Sr
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks for the helping info. I like the domain it is neat here. Also the happiest new years to you.
 
Just let me do the talking. Ahem ... so ... you see ... we have this tiny ad...
SKIP - a book about connecting industrious people with elderly land owners
https://coderanch.com/t/skip-book
reply
    Bookmark Topic Watch Topic
  • New Topic