• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Jeanne Boyarsky
  • Liutauras Vilda
Sheriffs:
  • Rob Spoor
  • Bear Bibeault
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Piet Souris
Bartenders:
  • Frits Walraven
  • Himai Minh

Why isn't @JmsListener in ActiveMQ working?

 
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
First, I made a test project to learn how to work with ActiveMQ. Everything worked there.

Here is the github link https://github.com/stavatar/TestJMSActiveMQ

But when I did the same with an already made application on Spring + Security + Jaas, then everything stopped working. And apparently the Listener class is not working. I sent messages to this queue via ActiveMQ admin but didn't work

Here is the github link https://github.com/stavatar/Lab3Buisness

 
Bartender
Posts: 2085
13
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
First I tried your TestJMSActiveMQ, I updated your spring-boot-starter-parent to version 2.4.1 instead.
I started docker run -p 8161:8161 -p 61616:61616 rmohr/activemq
I ran both client 1 and client 2.
But I did not see anything in the queues in from localhost:8161.
 
reply
    Bookmark Topic Watch Topic
  • New Topic