Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Rob Spoor
  • Bear Bibeault
Saloon Keepers:
  • Jesse Silverman
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Al Hobbs
  • salvin francis

Micro service troubles only while debugging

 
Ranch Hand
Posts: 269
1
jQuery Spring Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Report post to moderator
Hi All Techies,

We're working in an environment with multiple microservices. While debugging between the services in the IntelliJ IDE, authorization problem raises only when debuggers' breakpoint flows through on some service connections which has to connect with another service to create a resource with POST call.  Ensured the same Bearer works if I mute the breakpoints of the IDE. If I unmute the problem reappers.  At many places, we've to debug beyond a point where the service connects another service on POST call and has to back to continue with the current service to bring up some outcome but in this the flow breaks and unable to proceed.

If anyone has any idea on this or came across this kind of issue, please share your thoughts/comments that helps me to investigate further of this case. Below is a reference where the flow breaks and log from the console.



Received status: 401 and error response: ErrorResponse{errors=[]} while invoking: OrdersToBasketApiClient#create(RequestDTO,String)

Best Regards,
 
Saloon Keeper
Posts: 7174
166
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Report post to moderator
Let's continue the discussion in the previous topic where you asked this question, and where you have an answer already: https://coderanch.com/t/743525/java/Micro-service-troubles-debugging
 
    Bookmark Topic Watch Topic
  • New Topic