• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

WSAD5 Server server1 failed to start

 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I got this error message when starting test server in wsad5
Any clue?
Thanks a lot.
*** Starting the server ***
************ Start Display Current Environment ************
WebSphere Platform 5.0 [BASE 5.0.0 s0245.03] running with process name localhost\localhost\server1 and process id 2608
Host Operating System is Windows 2000, version 5.0
Java version = J2RE 1.3.1 IBM Windows 32 build cn131-20021107 (JIT enabled: jitc), Java Compiler = jitc, Java VM name = Classic VM
was.install.root = C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5
user.install.root = C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5
Java Home = C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5\java\jre
ws.ext.dirs = C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/java/lib;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/classes;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/classes;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/lib;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/lib/ext;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/web/help;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/deploytool/itp/plugins/com.ibm.etools.ejbdeploy/runtime;C:/SQLLIB/java/db2java.zip;C:/Program Files/IBM/WebSphere Studio/wstools/eclipse/plugins/com.ibm.etools.webservice_5.0.2/runtime/worf.jar
Classpath = C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/properties;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/properties;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/lib/bootstrap.jar;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/lib/j2ee.jar;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/lib/lmproxy.jar;C:\EEER_Workspace5_1.4_Was5\config;C:/Program Files/IBM/WebSphere Studio/wstools/eclipse/plugins/com.ibm.etools.websphere.tools.common_5.0.2/runtime/wteServers.jar;C:/Program Files/IBM/WebSphere Studio/wstools/eclipse/plugins/com.ibm.etools.websphere.tools.common_5.0.2/runtime/wasToolsCommon.jar
Java Library path = C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/bin;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/java/bin;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/java/jre/bin;C:\Program Files\IBM\WebSphere Studio\eclipse\jre\bin;.;C:\WINNT\System32;C:\WINNT;C:\Program Files\ibm\gsk5\lib;C:\IBMDebug\bin;C:\PROGRA~1\RATIONAL\RATION~1\NUTCROOT\bin;C:\PROGRA~1\RATIONAL\RATION~1\NUTCROOT\bin\x11;C:\PROGRA~1\RATIONAL\RATION~1\NUTCROOT\mksnt;C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem;C:\Program Files\Executive Software\DiskeeperWorkstation\;C:\WINNT\system32\nls;C:\WINNT\system32\nls\ENGLISH;C:\Program Files\Microsoft SQL Server\80\Tools\BINN;C:\Program Files\Rational\common;C:\Program Files\Rational\Rose\TopLink\;C:\Program Files\Rational\Rational Test;C:\WebSphere\AppServer\bin;C:\SQLLIB\BIN;C:\SQLLIB\SAMPLES\REPL;C:\SQLLIB\HELP;C:\IBM\IMNNQ;C:\Program Files\Common Files\Adaptec Shared\System;C:\VisualCafe\BIN;C:\VisualCafe\JAVA\BIN;Y:.;Z:.;;C:\PROGRA~1\E!PC
************* End Display Current Environment *************
[1/23/04 8:53:22:219 PST] 668c1081 ManagerAdmin I TRAS0017I: The startup trace state is *=all=disabled.
[1/23/04 8:53:23:188 PST] 668c1081 AdminInitiali A ADMN0015I: AdminService initialized
[1/23/04 8:53:25:281 PST] 668c1081 Configuration A SECJ0215I: Successfully set JAAS login provider configuration class to com.ibm.ws.security.auth.login.Configuration.
[1/23/04 8:53:25:344 PST] 668c1081 SecurityDM I SECJ0231I: The Security component's FFDC Diagnostic Module com.ibm.ws.security.core.SecurityDM registered successfully: true.
[1/23/04 8:53:25:938 PST] 668c1081 SecurityCompo I SECJ0309I: Java 2 Security is disabled.
[1/23/04 8:53:25:953 PST] 668c1081 SecurityCompo I SECJ0212I: WCCM JAAS configuration information successfully pushed to login provider class.
[1/23/04 8:53:26:031 PST] 668c1081 SecurityCompo I SECJ0240I: Security service initialization completed successfully
[1/23/04 8:53:26:062 PST] 668c1081 JMSRegistrati A MSGS0602I: WebSphere Embedded Messaging Client only has been installed
[1/23/04 8:53:28:984 PST] 668c1081 JMXSoapAdapte A ADMC0013I: SOAP connector available at port 8880
[1/23/04 8:53:29:016 PST] 668c1081 SecurityCompo I SECJ0243I: Security service started successfully
[1/23/04 8:53:29:016 PST] 668c1081 SecurityCompo I SECJ0210I: Security enabled false
[1/23/04 8:53:30:641 PST] 668c1081 ResourceMgrIm I WSVR0049I: Binding p1a1dmt6_CF as eis/jdbc/p1a1dmt2_CMP
[1/23/04 8:53:30:703 PST] 668c1081 ResourceMgrIm I WSVR0049I: Binding p1a1dmt6 as jdbc/p1a1dmt2
[1/23/04 8:53:31:656 PST] 668c1081 CacheServiceI I DYNA0048I: WebSphere Dynamic Cache initialized successfully.
[1/23/04 8:53:36:469 PST] 668c1081 ApplicationMg A WSVR0200I: Starting application: IBMUTC
[1/23/04 8:53:36:828 PST] 668c1081 WebContainer A SRVE0161I: IBM WebSphere Application Server - Web Container. Copyright IBM Corp. 1998-2002
[1/23/04 8:53:36:859 PST] 668c1081 WebContainer A SRVE0162I: Servlet Specification Level: 2.3
[1/23/04 8:53:36:891 PST] 668c1081 WebContainer A SRVE0163I: Supported JSP Specification Level: 1.2
[1/23/04 8:53:37:000 PST] 668c1081 WebContainer A SRVE0169I: Loading Web Module: IBM Universal Test Client.
[1/23/04 8:53:37:344 PST] 668c1081 WebGroup I SRVE0180I: [IBM Universal Test Client] [/UTC] [Servlet.LOG]: JSP 1.2 Processor: init
[1/23/04 8:53:37:453 PST] 668c1081 WebGroup I SRVE0180I: [IBM Universal Test Client] [/UTC] [Servlet.LOG]: SimpleFileServlet: init
[1/23/04 8:53:37:578 PST] 668c1081 ApplicationMg A WSVR0221I: Application started: IBMUTC
[1/23/04 8:53:37:594 PST] 668c1081 ApplicationMg A WSVR0200I: Starting application: EEER
[1/23/04 8:53:37:734 PST] 668c1081 ApplicationMg E WSVR0101W: An error occurred starting, EEER
[1/23/04 8:53:37:750 PST] 668c1081 ApplicationMg A WSVR0217I: Stopping application: EEER
[1/23/04 8:53:37:844 PST] 668c1081 ApplicationMg A WSVR0220I: Application stopped: EEER
[1/23/04 8:53:42:891 PST] 668c1081 ApplicationMg A WSVR0217I: Stopping application: IBMUTC
[1/23/04 8:53:42:906 PST] 668c1081 WebContainer A SRVE0170I: Stopping Web Module: IBM Universal Test Client.
[1/23/04 8:53:42:922 PST] 668c1081 WebGroup I SRVE0180I: [IBM Universal Test Client] [/UTC] [Servlet.LOG]: SimpleFileServlet: destroy
[1/23/04 8:53:43:047 PST] 668c1081 WebGroup I SRVE0180I: [IBM Universal Test Client] [/UTC] [Servlet.LOG]: JSP 1.2 Processor: destroy
[1/23/04 8:53:43:094 PST] 668c1081 ApplicationMg A WSVR0220I: Application stopped: IBMUTC
[1/23/04 8:53:43:344 PST] 668c1081 WsServer E WSVR0003E: Server server1 failed to start
com.ibm.ws.exception.RuntimeError
at com.ibm.ws.runtime.component.ApplicationMgrImpl.startApplication(ApplicationMgrImpl.java:268)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:232)
at com.ibm.ws.runtime.component.ContainerImpl.startComponents(ContainerImpl.java:343)
at com.ibm.ws.runtime.component.ContainerImpl.start(ContainerImpl.java:234)
at com.ibm.ws.runtime.component.ApplicationServerImpl.start(ApplicationServerImpl.java:117)
at com.ibm.ws.runtime.component.ContainerImpl.startComponents(ContainerImpl.java:343)
at com.ibm.ws.runtime.component.ContainerImpl.start(ContainerImpl.java:234)
at com.ibm.ws.runtime.component.ServerImpl.start(ServerImpl.java:182)
at com.ibm.ws.runtime.WsServer.start(WsServer.java:135)
at com.ibm.ws.runtime.WsServer.main(WsServer.java:232)
at java.lang.reflect.Method.invoke(Native Method)
at com.ibm.ws.bootstrap.WSLauncher.main(WSLauncher.java:94)
at com.ibm.etools.websphere.tools.runner.api.ServerRunnerV5$1.run(ServerRunnerV5.java:97)
---- Begin backtrace for nested exception
java.lang.NullPointerException
at com.ibm.ejs.csi.ResRefListImpl.initializeIsolationLevel(ResRefListImpl.java:169)
at com.ibm.ejs.csi.ResRefListImpl.<init>(ResRefListImpl.java:127)
at com.ibm.ejs.csi.ResRefListImpl.<init>(ResRefListImpl.java:113)
at com.ibm.ws.webcontainer.metadata.WebMetaDataFactory.createMetaData(WebMetaDataFactory.java:127)
at com.ibm.ws.runtime.component.MetaDataMgrImpl.createFactoryMetaData(MetaDataMgrImpl.java:115)
at com.ibm.ws.runtime.component.MetaDataMgrImpl.createMetaData(MetaDataMgrImpl.java:159)
at com.ibm.ws.runtime.component.DeployedModuleImpl.start(DeployedModuleImpl.java:333)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.start(DeployedApplicationImpl.java:531)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.startApplication(ApplicationMgrImpl.java:254)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:232)
at com.ibm.ws.runtime.component.ContainerImpl.startComponents(ContainerImpl.java:343)
at com.ibm.ws.runtime.component.ContainerImpl.start(ContainerImpl.java:234)
at com.ibm.ws.runtime.component.ApplicationServerImpl.start(ApplicationServerImpl.java:117)
at com.ibm.ws.runtime.component.ContainerImpl.startComponents(ContainerImpl.java:343)
at com.ibm.ws.runtime.component.ContainerImpl.start(ContainerImpl.java:234)
at com.ibm.ws.runtime.component.ServerImpl.start(ServerImpl.java:182)
at com.ibm.ws.runtime.WsServer.start(WsServer.java:135)
at com.ibm.ws.runtime.WsServer.main(WsServer.java:232)
at java.lang.reflect.Method.invoke(Native Method)
at com.ibm.ws.bootstrap.WSLauncher.main(WSLauncher.java:94)
at com.ibm.etools.websphere.tools.runner.api.ServerRunnerV5$1.run(ServerRunnerV5.java:97)
[1/23/04 8:53:43:375 PST] 668c1081 WsServer E WSVR0009E: Error occurred during startup
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I am seeing the exact same exception (WAS 5.1). Any feedback on how you resolved this would be appreciated.

Thanks,
Andal.
 
Ranch Hand
Posts: 724
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Starting application: EEER

What is this?
Your application?
Check it, try to undeploy it.


Binding p1a1dmt6 as jdbc/p1a1dmt2
Binding p1a1dmt6_CF as eis/jdbc/p1a1dmt2_CMP

What is this? Check also this.
 
Ranch Hand
Posts: 662
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I fought the same error sometime back. It came down to the fact that my web.xml has two jndi references for jdbc and i had to put in the ref ids in there extracted from the websphere binding xmi files.

Took out the xml tags. The element names are not showing up if i have a well-formed xml. Not sure why !!!

web.xml snippet below -

resource-ref id="ResourceRef_1083270960234"
description>USERS DB Connection/description
res-ref-name>jdbc/USERSDB/res-ref-name
res-type>javax.sql.DataSource/res-type
res-auth>Container/res-auth>
res-sharing-scope>Shareable</res-sharing-scope>
/resource-ref

ibm-web-bnd.xmi file snippet below -

resRefBindings xmi:id="ResourceRefBinding_1088201702343" jndiName="jdbc/USERSDB"
bindingResourceRef href="WEB-INF/web.xml#ResourceRef_1083270960234"
/resRefBindings

This took care of the isolation problem.

Hope this helps.

[ November 10, 2004: Message edited by: Jayadev Pulaparty ]

[ November 10, 2004: Message edited by: Jayadev Pulaparty ]

[ November 10, 2004: Message edited by: Jayadev Pulaparty ]
[ November 10, 2004: Message edited by: Jayadev Pulaparty ]
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I got this same error following the installation of a JVM application in WAS 5.1.1.3. After examining the SystemOut.log file, above the location where the error appeared, I noticed that, whenever I would run startServer.sh server1, WebSphere would not only try to start server1, but would also attempt to start, then stop, the Sample applications, such as PlantsbyWebsphere, etc...

At this point, I don't know why Websphere was attempting to start and stop all of these sample apps during the start routine for server1.

However, I was able to resolve this by going into

<WAS Home>/config/cells/<cellname>/applications

then removing the .ear files for the sample applications. I still don't know what it was within those applicaitons that was bound to the start routine of server1, but deleting these corrected the problem.
 
reply
    Bookmark Topic Watch Topic
  • New Topic