• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Tim Cooke
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Paul Clapham
  • Rob Spoor
  • Junilu Lacar
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Piet Souris
  • Carey Brown
Bartenders:

Problems starting default server in WSAD 5.0

 
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I get the following when I attempt to start the default server in WSAD 5.0.
java.lang.NoClassDefFoundError: 2004/LabsWorkSpace/Servers/defaultConfiguration/wsc
Exception in thread "main"
Below is what I find in the propeties of the default server in Debug perspective.
C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/java/bin/javaw -Xbootclasspath/p:C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/java/jre/lib/ext/ibmorb.jar;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/java/jre/lib/ext/ibmext.jar -DPD_DT_ENABLED=true -Ddb2j.system.home=C:/CPT350/Spring 2004/LabsWorkSpace/.metadata/.plugins/com.ibm.etools.server.core/tmp0/databases -Dcom.ibm.ws.tools.trace.traceFile=C:/CPT350/Spring 2004/LabsWorkSpace/.metadata/.plugins/com.ibm.etools.server.core/tmp0/logs/startServer.log -Dworkspace.user.root=C:/CPT350/Spring 2004/LabsWorkSpace/.metadata/.plugins/com.ibm.etools.server.core/tmp0/wstemp -Dworkspace.repository.adapter=com.ibm.ws.sm.workspace.impl.WorkSpaceSelfRepositoryAdapter -Dworkspace.root=C:/CPT350/Spring 2004/LabsWorkSpace/Servers/defaultConfiguration.wsc -Dcom.ibm.websphere.servlet.temp.dir=C:/CPT350/Spring 2004/LabsWorkSpace/.metadata/.plugins/com.ibm.etools.server.core/tmp0/cache -Dwas.repository.backup=C:/CPT350/Spring 2004/LabsWorkSpace/.metadata/.plugins/com.ibm.etools.server.core/tmp0/repository/backup -Dwas.repository.temp=C:/CPT350/Spring 2004/LabsWorkSpace/.metadata/.plugins/com.ibm.etools.server.core/tmp0/repository/temp -Dwas.repository.config=C:/CPT350/Spring 2004/LabsWorkSpace/.metadata/.plugins/com.ibm.etools.server.core/tmp0/repository -Dwas.repository.root=C:/CPT350/Spring 2004/LabsWorkSpace/.metadata/.plugins/com.ibm.etools.server.core/tmp0/repository -Dwas.loose.config=file:C:/CPT350/Spring 2004/LabsWorkSpace/.metadata/.plugins/com.ibm.etools.server.core/tmp0/looseconfig.xmi -Dwas.variable.map=C:\CPT350\Spring 2004\LabsWorkSpace\.metadata\.plugins\com.ibm.etools.server.core\tmp0\pathMaps.properties -classpath C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/properties;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/properties;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/lib/bootstrap.jar;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/lib/j2ee.jar;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/lib/lmproxy.jar;C:/Program Files/IBM/WebSphere Studio/wstools/eclipse/plugins/com.ibm.etools.websphere.tools.common_5.0.2/runtime/wteServers.jar;C:/Program Files/IBM/WebSphere Studio/wstools/eclipse/plugins/com.ibm.etools.websphere.tools.common_5.0.2/runtime/wasToolsCommon.jar -Xmx256m -Dws.ext.dirs=C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/java/lib;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/classes;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/classes;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/lib;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/lib/ext;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/web/help;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/deploytool/itp/plugins/com.ibm.etools.ejbdeploy/runtime;C:/Program Files/IBM/WebSphere Studio/wstools/eclipse/plugins/com.ibm.etools.webservice_5.0.2/runtime/worf.jar -Dserver.root=C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5 -Duser.install.root=C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5 -Dcom.ibm.itp.location=C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/bin -Dwas.install.root=C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5 -Djava.security.auth.login.config=C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/properties/wsjaas.conf -Djava.security.policy=C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/properties/server.policy -Djava.library.path=C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/bin;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/java/bin;C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5/java/jre/bin;C:\Program Files\IBM\WebSphere Studio\eclipse\jre\bin;.;C:\WINDOWS\System32;C:\WINDOWS;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\Common Files\Adaptec Shared\System;C:\j2sdk1.4.2_01\bin;C:\Program Files\Executive Software\Diskeeper\;C:\Program Files\Microsoft Office\OFFICE11\Business Contact Manager\IM;C:\Program Files\Microsoft SQL Server\80\Tools\Binn\;C:\Program Files\Microsoft Office\OFFICE11\Business Contact Manager\;C:\Program Files\Norton SystemWorks\Norton Ghost\ com.ibm.etools.websphere.tools.runner.UnitTestServerRunnerV5 1046 C:/CPT350/Spring 2004/LabsWorkSpace/Servers/defaultConfiguration.wsc -1 localhost localhost server1
Thank You Very Much
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
The problem seems to be in your classloader,
WEBSPHERE most of the times ,has trobles handeling one classloader
over multiple applications.

My advice to you:
If the class loader is single ,switch it to multiple.
and the try restarting your app.
 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic