• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Junilu Lacar
Sheriffs:
  • Rob Spoor
  • Liutauras Vilda
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Piet Souris
  • Tim Holloway
  • Jj Roberts
  • Stephan van Hulst
Bartenders:
  • Himai Minh
  • Carey Brown
  • Frits Walraven

WSAD 5.1: Failed to load servlet, NoClassDefFoundError

 
Ranch Hand
Posts: 427
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I am using Websphere Studio Application Developer 5.1 on Windows 2000.
I created a Web project and a Server project.
The Server project type is Websphere Test Environment 4.0
When I start the server in WSAD, the server fails to launch.
I am seeing this error:
[2/6/04 17:50:02:402 PST] 7fa04f86 WebGroup X Servlet Error-[AutomotiveServlet]: Failed to load servlet:
java. lang.NoClassDefFoundError:
org/apache/commons/logging/LogFactory
at foobar.ControlServlet.<clinit>(ControlServlet.java:25)
at java.lang.Class.newInstance0(Native Method)
at java.lang.Class.newInstance(Class.java:262)
at java.beans.Beans.instantiate(Beans.java:233)
at java.beans.Beans.instantiate(Beans.java:77)
at com.ibm.servlet.engine.webapp.WebAppServletManager.loadServlet(WebAppServletManager.java:141)
at com.ibm.servlet.engine.webapp.WebAppServletManager.getServletReference(WebAppServletManager.java:254)
at com.ibm.servlet.engine.webapp.WebApp.getServletReference(WebApp.java:388)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcherInfo.calculateInfo(WebAppRequestDispatcherInfo.java:167)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcherInfo.<init>(WebAppRequestDispatcherInfo.java:51)
at com.ibm.servlet.engine.webapp.WebApp.getRequestDispatcher(WebApp.java:1355)
at com.ibm.servlet.engine.srt.WebAppInvoker.handleInvocationHook(WebAppInvoker.java:234)
at com.ibm.servlet.engine.invocation.CachedInvocation.handleInvocation(CachedInvocation.java:67)
at com.ibm.servlet.engine.srp.ServletRequestProcessor.dispatchByURI(ServletRequestProcessor.java:151)
at com.ibm.servlet.engine.oselistener.OSEListenerDispatcher.service(OSEListener.java:317)
at com.ibm.servlet.engine.http11.HttpConnection.handleRequest(HttpConnection.java:60)
at com.ibm.ws.http.HttpConnection.readAndHandleRequest(HttpConnection.java:391)
at com.ibm.ws.http.HttpConnection.run(HttpConnection.java:284)
at com.ibm.ws.util.CachedThread.run(ThreadPool.java:144)
[2/6/04 17:50:02:402 PST] 7fa04f86 WebGroup X SRVE0026E: [Servlet Error]-[AutomotiveServlet]:
java .lang.NoClassDefFoundError:
org/apache/commons/logging/LogFactory
at foobar.ControlServlet.<clinit>(ControlServlet.java:25)
at java.lang.Class.newInstance0(Native Method)
at java.lang.Class.newInstance(Class.java:262)
at java.beans.Beans.instantiate(Beans.java:233)
at java.beans.Beans.instantiate(Beans.java:77)
at com.ibm.servlet.engine.webapp.WebAppServletManager.loadServlet(WebAppServletManager.java:141)
at com.ibm.servlet.engine.webapp.WebAppServletManager.getServletReference(WebAppServletManager.java:254)
at com.ibm.servlet.engine.webapp.WebApp.getServletReference(WebApp.java:388)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcherInfo.calculateInfo(WebAppRequestDispatcherInfo.java:167)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcherInfo.<init>(WebAppRequestDispatcherInfo.java:51)
at com.ibm.servlet.engine.webapp.WebApp.getRequestDispatcher(WebApp.java:1355)
at com.ibm.servlet.engine.srt.WebAppInvoker.handleInvocationHook(WebAppInvoker.java:234)
at com.ibm.servlet.engine.invocation.CachedInvocation.handleInvocation(CachedInvocation.java:67)
at com.ibm.servlet.engine.srp.ServletRequestProcessor.dispatchByURI(ServletRequestProcessor.java:151)
at com.ibm.servlet.engine.oselistener.OSEListenerDispatcher.service(OSEListener.java:317)
at com.ibm.servlet.engine.http11.HttpConnection.handleRequest(HttpConnection.java:60)
at com.ibm.ws.http.HttpConnection.readAndHandleRequest(HttpConnection.java:391)
at com.ibm.ws.http.HttpConnection.run(HttpConnection.java:284)
at com.ibm.ws.util.CachedThread.run(ThreadPool.java:144)

I've got commons-logging.jar listed in the "Web Library Projects"
Why is this failing?
 
reply
    Bookmark Topic Watch Topic
  • New Topic