• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

Illegal use of 1PC resource in transaction

 
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,
Need Urgent help on a issus encountered in WSAD 4.0.3
I have a stateless session bean, which call a method whose transaction attribute is set to "NotSupported" type. The method queries 2 different databases. I am able to connnect & retrieve result from the first query which connects to DataSource1. The returned result is used in the where clause of the 2nd query which connnects to DataSource2. I am able to perform jndi look-up and obtain connection to DataSource2, but query exceution against this datasource fails and results in the following error..
"Illegal use of 1PC resource in transaction".
DataSource1 --> UDB DB2 7.0
DataSource2 --> Sybase
Your help will be greatly appreciated.
Thanks
 
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've had similar problems. It seems to occur regardless of the container transaction setting. You may want to try useing an XA dasasource. I was unable to get one to work in my implementation but I think the solution may work. I look forward to seeing if someone found a sure solution to this problem.
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!