Win a copy of Building Blockchain Apps this week in the Cloud/Virtualization forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Liutauras Vilda
  • Knute Snortum
  • Bear Bibeault
Sheriffs:
  • Devaka Cooray
  • Jeanne Boyarsky
  • Junilu Lacar
Saloon Keepers:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
  • salvin francis
Bartenders:
  • Tim Holloway
  • Piet Souris
  • Frits Walraven

websphere 3.5.7 and jdk 1.4

 
Ranch Hand
Posts: 72
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
On Windows 2000 and Websphere 3.5.7 we are using a simple application with only a few servlets. No EJB's, etc.
Will the application work o.k if the application classes use JDK 1.4.2? Can the JVM used by Websphere 3.5.7 handle handle such an application? What are other things that need to be investigated for such a migration.
Thanks
 
Ranch Hand
Posts: 3451
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi forumer,
Welcome to JavaRanch, the absolute best site on the www for Java information. We don't have many rules around here, but we do have one. Please change your display name to a first and last name to comply with the JavaRanch Naming Policy. You can change it here. Thank you for your cooperation.
As for your quesition, the answer is probably no, I don't think any WebSphere version before 5.x can use J2SE 1.4. We are using 5.02 and are still stuck at J2SE 1.3 and J2EE 1.3. Life would be much easier if we had some of the features of 1.4!
 
Anne Forumer
Ranch Hand
Posts: 72
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks!
Do you know why it is so? Is it because the JVM cannot support features required by 1.4 or are there other reasons?
 
tumbleweed
Posts: 5089
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Websphere 3.5.x only supports up to SDK 1.2 see Chapter 2 - What is new
[ April 19, 2004: Message edited by: Johannes de Jong ]
 
Anne Forumer
Ranch Hand
Posts: 72
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am not looking for the underlying reason why 3.5 wouldn't work with JDK 1.4 code. Is the JVM not able to interpret bytecodes generated by JDK1.4? or is there some other reason? I am not looking for any special AppServer features. We only have very simple Servlets.
Thanks
 
Ranch Hand
Posts: 155
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Originally posted by Anne Forumer:
[QB]Is the JVM not able to interpret bytecodes generated by JDK1.4?[QB]


Yes.
Why can't you just compile your application with jdk 1.2?
If your application is small as you said, refer to the javadoc to verify that the classes you are using are jdk 1.2 compliant.
 
Anne Forumer
Ranch Hand
Posts: 72
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Because I will like to use JDK1.4 features in my application (business-classes) without using any fancy application-server features.
 
author
Posts: 3892
5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
WebSphere requires the JVM it is built on because its internals use the special IBM CORBA classes that are part of its ORB. If you replace it with a later JDK (or one that is not from IBM) then the classes will probably be different. In any case, if you do replace the JDK you have just violated your warranty and IBM will not take support calls on your setup.
If you need JDK 1.4, upgrade to WebSphere 5.1.
Kyle
 
Anne Forumer
Ranch Hand
Posts: 72
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have no intention of replacing anything inside Websphere. All I want to do is design my business-classes using JDK1.4 because of JDK1.4-features I need. Compile these classes and place it into Websphere 3.5.7 as an application with a few simple servlets.
Will this work? Why or Why not?
Thanks for your insight.
P.S We have already been working with this application compiled with JDK1.3
 
Brahim Bakayoko
Ranch Hand
Posts: 155
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Originally posted by Anne Forumer:
I have no intention of replacing anything inside Websphere. All I want to do is design my business-classes using JDK1.4 because of JDK1.4-features I need. Compile these classes and place it into Websphere 3.5.7 as an application with a few simple servlets.
Will this work? Why or Why not?
Thanks for your insight.
P.S We have already been working with this application compiled with JDK1.3


You really crack me up...
No seriously... the container (i.e Websphere) has to implement many of the interfaces defined in the API. JDK 1.4 introduced many new features as you know and deprecated many others. It is a lot of work to support a JDK version. So, who ever does it wants to charge you for it.
If you want JDK 1.4 support (only partial support so far), you need to buy Websphere 5.1; not even version 5.0 will do. Remember, the API is not a library but rather a specification that gets implemented.
Last, there is more to it than just providing implementation classes for the specification. Vendors also need to provide tools that go along with the new features, update their IDEs, etc.
Now, I don't know if I should share this, but you can always disassemble the required classes, package them the way you want, then deploy them as library. Google for FrontEnd Plus and go from there.
 
Ranch Hand
Posts: 106
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
Yes its right that we cannot use jdk1.4 with Websphere 3.X ,4.x and 5.0 as well. I was also trying the same thing, to get the jdk1.4 nio classes to work in WSAD5.0 but it didnt work because WSAD5.0 supports only Jdk1.3 . So i would suggest to use WSAD5.1 to use jdk1.4.
Thx
 
Brahim Bakayoko
Ranch Hand
Posts: 155
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Originally posted by Steve Grant:
Hi,
So i would suggest to use WSAD5.1 to use jdk1.4.
Thx


Actually, WSAD 5.1.1 and WSAS 5.1. WSAD 5.1 is still j2ee 1.3 (WSAS 5.0.2).
 
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am in the process of migrating WebSphere 3.5 application to 5.1. I am successful in doing so. I have migrated my application in WSAD 5.1, it runs fine with no issues. But when I am deploying the same war file in WAS 5.1 its giving javascript error when my report result page is trying to load. The same war works in WSAD 5.1. Do I need to do any extra settings in WAS 5.1 to make this work?. Help needed.

Thanks in advance,
Praveen K
 
Everyone is a villain in someone else's story. Especially this devious tiny ad:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!