• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Junilu Lacar
  • Liutauras Vilda
Sheriffs:
  • Paul Clapham
  • Jeanne Boyarsky
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Piet Souris
  • Carey Brown
Bartenders:
  • Jesse Duncan
  • Frits Walraven
  • Mikalai Zaikin

How can I change installed OpenGL version to higher than 3.1?

 
Ranch Hand
Posts: 56
2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I installed Debian 11 Bullseye but it loaded AMD-GPU drivers. I have an Defold game engine which needs OpenGL higher than 3.1.

I saw below in OpenGL in Debian Linux :

As we know, OpenGL is only really a specification that is implemented insider of the driver that your graphics card supports



And I found that : Debian OpenGL version check
I looked :

$glxinfo | grep "core profile"
   Max core profile version: 3.3
OpenGL core profile version string: 3.3 (Core Profile) Mesa 20.3.5
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:

So it gives OpenGL 3.3. But program does not work since it gives that error :

com.jogamp.opengl.GLException: JavaFX Application Thread: createImpl ARB n/a but required, profile > GL2 requested (OpenGL >= 3.1). Requested: GLProfile[GL3bc/GL3bc.hw], current: 3.0 (Compat profile, compat[ES2], FBO, hardware) - 3.0 Mesa 20.3.5

In its own forum page(Defold forums it says :


Since I see Mesa there, I assume you’re on Linux and you didn’t install the drivers for your graphics card. Mesa is the software rendering implementation of OpenGL, which is SLOW and incomplete.



Ok, I had a Mesa but my graphic cards and Mesa version support OpenGL 3.3. Why I got this error? How can I solve it? Because program does not work as expected. Any help is appreciated.
 
Hope Spartan
Ranch Hand
Posts: 56
2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
My installed graphics card driver is :

https://packages.debian.org/bullseye/firmware-amd-graphics

 
Hope Spartan
Ranch Hand
Posts: 56
2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
OK! I solved the problem with program's own command I found in change OpenGL version while starting


$ MESA_GL_VERSION_OVERRIDE=3.3 ./Defold

Above code worked like a magic! You can also create shell script to start Defold with above command as:



and create a .desktop file to start it on your desktop too if you want.

 
Hope Spartan
Ranch Hand
Posts: 56
2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Campbell Ritchie wrote:Please don't edit the thread title, but use the button below instead.



Ok. I clicked on "Resolved" since I did not see "tick mark" button.
 
Master Rancher
Posts: 245
9
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Well, although this is a week old and marked as solved: What GPU do you use specifically?

Reason I ask: I run Arch and until its death used a R9 290X - which, although supported by the AMDGPU driver defaulted to the older RADEON driver unless specific kernel boot options to override this behavious.

Debian, which is on a WAY slower pace than Arch and hence although stable uses quite old stuff - most 6 months or older - maybe due to some specific quirks about the specific GPU used could had defaulted to an older driver than required for the higher OGL level.

On my 290x defaulting to the radeon driver resulted in vulkan not working - although the card supports (/supported? hence it's dead) vulkan. Only manually overriding to use amdgpu driver made vulkan working.

TLDR: forcing a higher reported compatbile version by applying an override doesn't sound right to me here as a valid "solution" but rather either the card is just too old or it's some driver issue due to old version of it.

A sudo lspci -v would reveal what card and what board partner and if it may list radeon as fallback driver.
 
Those cherries would go best on cherry cheesecake. Don't put those cherries on this tiny ad:
Free, earth friendly heat - from the CodeRanch trailboss
https://www.kickstarter.com/projects/paulwheaton/free-heat
reply
    Bookmark Topic Watch Topic
  • New Topic