This week's book giveaway is in the OO, Patterns, UML and Refactoring forum.
We're giving away four copies of Five Lines of Code and have Christian Clausen on-line!
See this thread for details.
Win a copy of Five Lines of Code this week in the OO, Patterns, UML and Refactoring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

WSAD Struts Support

 
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I recently added the struts 1.0 framework to a project with the help of WSAD's strut support. When adding the struts framework to my web project, a number of jars were added to the /lib directory including the jdbc2_0-stdext.jar
Everything worked fine in my development environment but when I deployed to WAS 4.0 I experienced problems with creating datasources in our EJBs. I do not access datasources within the struts framework but I understand it is an optional feature. I do however use datasources regularly within our EJB container and this is where the problem arises.
This appears to be a classloader issue as two DataSource definitions exist in j2ee.jar and jdbc2_0-stdext.jar. I removed the jdbc2_0-stdext.jar from the /lib directory, redeployed and this solved the problem.
My question: can I safely remove this jar from the /lib directory without affecting the stability of the struts framework? Any help is appreciated.....
-D
 
Ranch Hand
Posts: 365
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Shouldn't be a problem.
 
Ranch Hand
Posts: 1551
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can you not run struts 1.1 in websphere 4?
 
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No..You can't.
Websphere 4.0 doesn't support struts 1.1
 
Dustin Whitte
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
WSAD 5.0 comes with a beta version of struts 1.1. I thought stuts to be somewhat self-sufficent, why doesn't WAS 4.0 support this version?
-D
 
WARNING! Do not activate jet boots indoors or you will see a tiny ad:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic