• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Jeanne Boyarsky
  • Liutauras Vilda
Sheriffs:
  • Rob Spoor
  • Bear Bibeault
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Piet Souris
Bartenders:
  • Frits Walraven
  • Himai Minh

Websphere 5.1 with db2 v7.2 FP 11

 
Greenhorn
Posts: 29
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I have my application running on WAS v5.1 and i need to connect the same to DB2 v7.2 . I created the datasource etc succesfully using the WAS Admin and when i test i.e "Test Connection" for the datasource , it says successfully connected. I am using "DB2 Universal JDBC Driver-compliant Provider" and have made sure that the jar files are all in place .
The Datasource Class name --> com.ibm.db2.jcc.DB2ConnectionPoolDataSource

The db2 server is on a different machine and i have no db2 client etc installed on the machine which contains the Application server.

When i run my application using above defined Datasource i get the following error :

B]ConnectionMan E J2CA0020E: The Connection Pool Manager could not allocate a Managed Connection: javax.resource.spi.ResourceAllocationException: DSRA8100E: Unable to get a PooledConnection from the DataSource.[/B]


Am also getting the follwoing error:

B]com.ibm.db2.jcc.b.SQLException: null user name not allowed with security mechanism
at com.ibm.db2.jcc.a.b.a(b.java:426)
at com.ibm.db2.jcc.a.b.a(b.java:293)
at com.ibm.db2.jcc.a.b.<init>(b.java:224)
at com.ibm.db2.jcc.a.c.<init>(c.java:31)
at com.ibm.db2.jcc.DB2PooledConnection.connect(DB2PooledConnection.java:107)
at com.ibm.db2.jcc.DB2PooledConnection.<init>(DB2PooledConnection.java:70)
at com.ibm.db2.jcc.DB2ConnectionPoolDataSource.getPooledConnection(DB2ConnectionPoolDataSource.java:77)
at com.ibm.db2.jcc.DB2ConnectionPoolDataSource.getPooledConnection(DB2ConnectionPoolDataSource.java:55)
at com.ibm.ws.rsadapter.DSConfigurationHelper$1.run(DSConfigurationHelper.java:688)
[/B]


What could be the reason for it to show success in WAS Admin and not working when i run the datasource using my application?

So i need to install the db2 client on the same machine as WAS v5.1?

Please help..

aanchal ..
[ July 08, 2004: Message edited by: aanchal mathur ]
 
Arthur, where are your pants? Check under this tiny ad.
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
reply
    Bookmark Topic Watch Topic
  • New Topic