Win a copy of Testing JavaScript Applications this week in the HTML Pages with CSS and JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
  • Piet Souris
  • Frits Walraven
  • Carey Brown

Javascript not executing in WSAD test server

Ranch Hand
Posts: 104
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm trying to use WSAD 5.1.2 to test a web project I created.
The problem I'm having seem to be that no javascript is executing.
It runs fine on other people's machines, even with the same machine model and operating system. I created a real simple web project with just 2 pages to illustrate the problem.

Unfornately, I seem unable to post any html even in code tags. So I'll have to just summarize parts of it.

The welcome.jsp just displays the userid:

On my machine, when I click the login, the WSAD browser does nothing. There's no alerts, no welcome page and no errors in the log or the console.
If I change action property directly to "welcome.jsp" and eliminate the on$click="doSumit()" from the login button then it works. However, I really need to use javascript to validate the form entries and it should work and does work on other machines. I even went so far as to completly uninstall and reinstall WSAD to no avail.

Any ideas on how to fix it?
Thanks in advance for any help offered.
Posts: 3892
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Javascript doesn't execute in the server, it executes on the browser. WSAD doesn't provide its own browser, it uses the copy of IE already installed on your Windows machine. If you have IE set up to not execute Javascript (you've set your security settings in IE to disable it) then it won't work.

Lu Battist
Ranch Hand
Posts: 104
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Kyle for responding.
That explation makes sense as hard as it was to hear. I would have assumed javascript to be on as remote web sites with javascript are working just fine for me. However, I probed all IE's security and privacy settings flipping on whatever sounded promising. Must have been off for just the local network or just my local machine. Anyway after some tinkering, that did the trick and it is working like it should.

Should anyone experience this kind of trouble using IE. Look under the security tab of Tools-InternetOptions for each security zone and select custom level, then toward the bottom there is a scripting section and one labeled active scripting. I believe this was the one that turned on javascripting for me.

Thanks a lot Kyle.
Forget this weirdo. You guys wanna see something really neat? I just have to take off my shoe .... (hint: it's a tiny ad)
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
    Bookmark Topic Watch Topic
  • New Topic