Win a copy of Machine Learning with R: Expert techniques for predictive modeling this week in the Artificial Intelligence and Machine Learning forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Junilu Lacar
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • Tim Cooke
  • Devaka Cooray
Saloon Keepers:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Ganesh Patekar

Help me!!!!!!!!!!

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,
I am having some difficulty creating servers by wsadmin on windows platform. I have one cluster (intra_cluster) and this cluster has two clusters member (Clone1,Clone2). I want to map two clusters to virtual host www_testhost (not default_host).pls help me.Thanks.
 
author
Posts: 3892
5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm confused. If you are making clusters (implying WebSphere ND) then for what parts are you using wsadmin? Tell us EXACTLY what you are trying to accomplish and the steps you are taking, and the errors you are seeing and we can try to help. Have you followed the sample scripts in the WebSphere Admin Handbook redbook? As it is, there's not enough information here to go on.

Kyle
[ August 09, 2004: Message edited by: Kyle Brown ]
 
Nguyen Van Thang
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Kyle Brown.
I must make an setup program. All code are included in this program. Users, who dosen't know anything about websphere can only run this setup program to set up an application.
So I must use wsadmin commands. Sorry for the last letter, I want to set (by command line, not map) the default virtual host of two clusters member to virtual host www_testhost (not default_host).
My machine was installed WS Application Server5.0 and WS Network Deployment5.0.
All main steps that are included in my setup program, following:
# machine's name is server

# begin create Clone1 server.
1. set node [$AdminConfig getid /Node:server/]
2. $AdminConfig create Server $node {{name Clone1}}
3. $AdminConfig save
# end create Clone1 server.

# begin convert Clone1 server to cluster.
4. set serverid [$AdminConfig getid /Server:Clone1/]
5. $AdminConfig convertToCluster $serverid intra_cluster
6. $AdminConfig save
# end convert Clone1 server to intra_cluster.

# begin add cluster member
7. set cluster [$AdminConfig getid /ServerCluster:intra_cluster/]
8. $AdminConfig createClusterMember $cluster $node {{memberName Clone2}}
9. $AdminConfig save
# end add cluster member

# begin modify servers's port
10. set as [$AdminConfig getid /Node:$Node/Server:Clone1/]
11. set webcontainer [$AdminConfig list WebContainer $as]
12. $AdminConfig modify $webcontainer {{transports:HTTPTransport {{{sslEnabled false} {address {{host *} {port 9093}}}}}}}
13. $AdminConfig modify $webcontainer {{transports:HTTPTransport {{{sslEnabled true} {sslConfig DefaultSSLSettings} {address {{host *} {port 9094}}}}}}}
14. $AdminConfig save

15. set as1 [$AdminConfig getid /Node:$Node/Server:Clone2/]
16. set webcontainer1 [$AdminConfig list WebContainer $as1]
17. $AdminConfig modify $webcontainer1 {{transports:HTTPTransport {{{sslEnabled false} {address {{host *} {port 9103}}}}}}}
18. $AdminConfig modify $webcontainer1 {{transports:HTTPTransport {{{sslEnabled true} {sslConfig DefaultSSLSettings} {address {{host *} {port 9104}}}}}}}
19. $AdminConfig save
# end modify servers's port

# begin Modify virtual host
20. set virtualhost [$AdminConfig getid /Cell:serverNetwork/]
21. $AdminConfig create VirtualHost $virtualhost {{name www_testhost}}
22. $AdminConfig save
23. set virtualhost [$AdminConfig getid /VirtualHost:www_testhost/]
24. $AdminConfig modify $virtualhost {{aliases {{{hostname *}{port 9093}}{{hostname *}{port 9094}}{{hostname *}{port 9095}}{{hostname *}{port 9096}}{{hostname www_testhost}{port 80}}}}}
25. $AdminConfig save
# end Modify virtual host

The command above is finished without any errors.
The problem is:
1. I don't know command line to delete default server ports (these ports was created
when creating servers)
2. I want to set (by command line) the default virtual host = www_testhost (not = default_host).

This can done with GUI
of administrative console:
Servers -> Application Servers -> Clone1 -> Web container: Default virtual host.
[ August 15, 2004: Message edited by: Nguyen Van Thang ]
 
Don't listen to Steve. Just read this tiny ad:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!