Win a copy of Testing JavaScript Applications this week in the HTML Pages with CSS and JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

Struts problem with Was5.1

 
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm having an issue with websphere 5.1 and tiles not rendering correctly with large amounts of data. Somehow the data seems to be interrupted randomly and doesn't produce the full html that I'm expecting. To me it sounds like a problem with buffers and flushing and eventually I found a workaround.
I makde a change in method doEndTag of InsertTag from this (that works fine with websphere 4.07):

// include requested component.
if (flush) {
pageContext.getOut().flush();
}
doInclude(page);

to this:

if (flush) {
pageContext.include(page);
} else {
TilesUtil.doInclude( page, (HttpServletRequest)pageContext.getRequest(),(HttpServletResponse)pageContext.getResponse(),pageContext.getServletContext());
}

Anyone experiencing i similar problem?
/C a Struts newbie
 
Then YOU must do the pig's work! Read this tiny ad. READ IT!
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic