Win a copy of 97 Things Every Java Programmer Should Know this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Sheriffs:
  • Ron McLeod
  • Devaka Cooray
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Frits Walraven
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • salvin francis
  • fred rosenberger

WAS 5.0 initialcontext calls never return for RMI client app

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am trying to make a client app connect to a EJB on a WAS 5.0 server. I am using a RMI/IIOP connection. Any call that attempts to access these components fails to return. For instance, a initialcontext.lookup can be called but will never return. Same with a listbindings. If I try to list the bindings in the cell area it fails to return.

This only occurs on our production servers. They are setup in a cluster. The same application on our test server (same OS and WAS) works fine. I can instantiate the EJBs and use them as designed. No exceptions are thrown and I can't find any reference to these connections in any WAS log files. I am using WSAD with a IBM JDK.
 
After some pecan pie, you might want to cleanse your palatte with this tiny ad:
Devious Experiments for a Truly Passive Greenhouse!
https://www.kickstarter.com/projects/paulwheaton/greenhouse-1
    Bookmark Topic Watch Topic
  • New Topic