• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

java.sql.SQLException: Parameter with index of 1 is not set.

 
Ranch Hand
Posts: 130
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I am using MySql and WSAD 5.1.2 , when I use the prepared statement I get the following error

java.sql.SQLException: Parameter with index of 1 is not set.

Has anyone encountered this and if anyone knows anything please let me know.

http://www-1.ibm.com/support/docview.wss?uid=swg1PQ91121#more

somebody has reported bug to ibm but it is for WAS and not WSAD...

Kyle can you please help ??

Thanks
Venkatesh Rajmendram
 
venkatesh rajmendram
Ranch Hand
Posts: 130
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
well I set the prepared statement cache to 0 in datasource setting, the error is gone.

But this is not a solution...the very purpose of using preparedstatement is kind of defeated since there is no caching....I guess there must be some other solution which I am not aware of or patch should be supplied by IBM WSAD group...

I guess MySql has nothing against DB2...There is a bigger fish to fry Oracle!!

- Venkatesh Rajmendram
 
Ranch Hand
Posts: 1087
Oracle Spring Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have faced this problem and end up with disabling cache
however I was co ordinating with IBM support and they couldn't provide me any other solution apart from this.
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
reply
    Bookmark Topic Watch Topic
  • New Topic