• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

WAS5 startup failing with runtime error

 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I disabled global secutiry and stopped the server and was trying to start it but it is failing during initialization with a runtime error. Any help would be really appreciated.

Thanks,
Kavita

My System.Out file shows the following exception:

[11/11/04 16:34:31:023 EST] 1dc64a5 WsServer E WSVR0003E: Server server1 f
ailed to start
com.ibm.ws.exception.RuntimeError
at com.ibm.ws.security.core.ServerSecurityComponentImpl.start(ServerSecu
rityComponentImpl.java:162)
at com.ibm.ws.runtime.component.ContainerImpl.startComponents(ContainerI
mpl.java:536)
at com.ibm.ws.runtime.component.ContainerImpl.start(ContainerImpl.java:4
13)
at com.ibm.ws.runtime.component.ApplicationServerImpl.start(ApplicationS
erverImpl.java:125)
at com.ibm.ws.runtime.component.ContainerImpl.startComponents(ContainerI
mpl.java:536)
at com.ibm.ws.runtime.component.ContainerImpl.start(ContainerImpl.java:4
13)
at com.ibm.ws.runtime.component.ServerImpl.start(ServerImpl.java:183)
at com.ibm.ws.runtime.WsServer.start(WsServer.java:128)
at com.ibm.ws.runtime.WsServer.main(WsServer.java:225)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
sorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at com.ibm.ws.bootstrap.WSLauncher.main(WSLauncher.java:94)
Caused by: com.ibm.ws.exception.WsRuntimeException
at com.ibm.ws.management.component.JMXConnectors.stateChanged(JMXConnect
ors.java:1236)
at com.ibm.ws.security.core.SecurityComponentImpl.fireStartedEvent(Secur
ityComponentImpl.java:858)
at com.ibm.ws.security.core.SecurityComponentImpl.startSecurity(Security
ComponentImpl.java:603)
at com.ibm.ws.security.core.ServerSecurityComponentImpl.start(ServerSecu
rityComponentImpl.java:157)
... 13 more
Caused by: java.lang.NullPointerException
at com.ibm.ws.management.component.JMXConnectors.startSOAPConnector(JMXC
onnectors.java:387)
at com.ibm.ws.management.component.JMXConnectors.stateChanged(JMXConnect
rs.java:1232)
... 16 more
---- Begin backtrace for nested exception
com.ibm.ws.exception.WsRuntimeException
at com.ibm.ws.management.component.JMXConnectors.stateChanged(JMXConnect
ors.java:1236)
at com.ibm.ws.security.core.SecurityComponentImpl.fireStartedEvent(Secur
ityComponentImpl.java:858)
at com.ibm.ws.security.core.SecurityComponentImpl.startSecurity(Security
ComponentImpl.java:603)
at com.ibm.ws.security.core.ServerSecurityComponentImpl.start(ServerSecu
rityComponentImpl.java:157)
at com.ibm.ws.runtime.component.ContainerImpl.startComponents(ContainerI
mpl.java:536)
at com.ibm.ws.runtime.component.ContainerImpl.start(ContainerImpl.java:4
13)
at com.ibm.ws.runtime.component.ApplicationServerImpl.start(ApplicationS
erverImpl.java:125)
at com.ibm.ws.runtime.component.ContainerImpl.startComponents(ContainerI
mpl.java:536)
at com.ibm.ws.runtime.component.ContainerImpl.start(ContainerImpl.java:4
13)
at com.ibm.ws.runtime.component.ServerImpl.start(ServerImpl.java:183)
at com.ibm.ws.runtime.WsServer.start(WsServer.java:128)
at com.ibm.ws.runtime.WsServer.main(WsServer.java:225)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
sorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at com.ibm.ws.bootstrap.WSLauncher.main(WSLauncher.java:94)
Caused by: java.lang.NullPointerException
at com.ibm.ws.management.component.JMXConnectors.startSOAPConnector(JMXC
onnectors.java:387)
at com.ibm.ws.management.component.JMXConnectors.stateChanged(JMXConnect
ors.java:1232)
 
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What's the version of your WAS?

I think we have the same problem a few months ago, and i think that there is a patch from the IBM Web Site.
 
Kavita Chinta
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It is WAS5.1. Please let me know what patch I can install. It looks like I am at dead end. Whatever I tried is not working.

Thanks,
Kavita
 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
HI,
How did you stop the server??? If you had started the server using first steps...with the global security on....you cannot stop the server through First steps you have to use he StopServer Command with from the command prompt...with the servername..UserID, Password... as the parameters..
Hope you might have tried this...

Asif
 
Kavita Chinta
Greenhorn
Posts: 3
  • Likes 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I resolved this problem. It looks like somehow my security.xml settings were messeup not sure how. I was playing around with the global security enabling and disabling through JACL scripts so I might have done something wrong. Anyways the way to manully fix this problem is described in the WAS support notes.

Application Server fails to start with WSVR0003E and NullPointerException in start SOAPConnector function
Technote (FAQ)

Problem
Application Server fails to start with a java.lang.NullPointerException in the SystemOut.log:

To see the full error text of the error log, click error.txt at the bottom of this technote.

Cause
This error is due to an unresolved variable in the
install_root /config/cell/<cell_name>/security.xml file.

& lt;repertoire xmi:id="SSLConfig_1" alias="$(node.name)/DefaultSSLSettings">

The $(node.name) variable is left unresolved and does not match the one set in
"cell/cell_name/nodes/node_name/servers/server_name/server.xml":

& lt;transports xmi:type="applicationserver.webcontainer:HTTPTransport" xmi:id="HTTPTransport_2" sslEnabled="true" sslConfig="ibm/DefaultSSLSettings">

Solution

Example:

Node Name = ibm
(Replace with your node name.)

The manual workaround for this problem is to edit the
install_root /config/cell/cell_name/security.xml file, and substitute the actual node name ibm for the $(node.name) variable.
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It resolved my issue also same stuff (difference between the security.xml of my cell and the server.xml)
 
You will always be treated with dignity. Now, strip naked, get on the probulator and hold this tiny ad:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic