• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

CMP 2.0 DB2 WSAD Exception

 
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Iam using WSAD 5.1.1. I created a CMP(2.0) bean with database IBM DB2 7.2. There were no problems during ejb-rdb mapping . But when I run the universal test client, and invoking any of the home interface methods like create or findByPrimaryKey, I get the following Exception:

RemoteException occurred in server thread; nested exception is: java.rmi.RemoteException: ; nested exception is: javax.ejb.EJBException: nested exception is: com.ibm.ws.ejbpersistence.utilpm.PersistenceManagerException: PMGR6022E: Error using adapter to create or execute an Interaction. ???


The server is a WebSphere 5.0 test env.
DataSource is Version 5.0
JDBC Provider Implementation Class Name : COM.ibm.db2.jdbc.DB2ConnectionPoolDataSource
DataSource Helper class is : com.ibm.websphere.rsadapter.DB2DataStoreHelper


I tried creating a CMP 1.1 bean with the same database table.
For this everything worked fine without any errors.

Kindly help me on this issue...
 
Good heavens! What have you done! Here, try to fix it with this tiny ad:
a bit of art, as a gift, that will fit in a stocking
https://gardener-gift.com
reply
    Bookmark Topic Watch Topic
  • New Topic