This week's book giveaway is in the Cloud forum.
We're giving away four copies of Terraform in Action and have Scott Winkler on-line!
See this thread for details.
Win a copy of Terraform in Action this week in the Cloud forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Rob Spoor
  • Bear Bibeault
Saloon Keepers:
  • Jesse Silverman
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Al Hobbs
  • salvin francis

Can't Start Adminclient Remotely

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I've looked over existing topics but I can't find the solution to my problem.

The reference book I'm using state that the following command is used to execute the adminclient.bat:

<WAS_HOME>/bin/adminclient <host name> <port#>

That's all fine and dandy. It then goes on to state that

"you can also launch the Administrative Console from a remote workstation by using the adminclient.bat file. The default port number is 900.

Yeah right!

I can't get this to work at all. I've tried everything I can think of. For the sake of argument that's assume that my server is literally called WAS. My installation is at D:\WebSphere on WAS. I have made a share called AppServer at D:\WebSphere\AppServer.

I then copied the adminclient.bat from the server to my workstation. I added environment variables to my workstation where WAS_HOME=\\WAS\AppServer and JAVA_HOME=\\WAS\\AppServer\java. I have created a local workstation batch file that executes

adminclient WAS 900

When running this I get a quick DOS box message saying that the remote adminserver will be accessed on port 900 but then nothing else. The Administrative Console doesn't open.

So I tried a different approach. I copied setupCmdLine.bat to my workstation as well but this didn't help.

Next I mapped a drive on the workstation where X:=AppServer on 'WAS' and modified my batch file to run

x:\bin\adminclient WAS 900

This caused this message:

Windows cannot find 'D:\WebSphere\AppServer\java\bin\javaw.'

What am I doing wrong? Why can't I get the Console to open on my workstation?
[ December 22, 2004: Message edited by: Jeff George ]
 
Ranch Hand
Posts: 365
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
To run the admin console on your machine that administers a remote WebSphere instance, you have to have actually install the client from the WebSphere CD and then specify the remote IP. You shouldn't have to copy anything to your machine.
 
Jeff George
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I installed to my Windows XP workstation using the following disc:

IBM WebSphere Application Server Advanced Single Server Edition v. 4.0.1.

However, this didn't install any adminclient.bat file to my system, and when I tried to run the menu based Administrative Console it attempted to open a web browser looking at my local client on port 9090, which resulted in nothing. I still don't know what I'm doing wrong.

I also have, in this same set of discs:

IBM WebSphere Application Server v. 5.0
Supplemental CD-ROMs v. 5.0 (contains Application Clients 1.3)
Deployment Manager CD-ROMs v. 5.0

Am I installing something incorrectly to result in not being able to remotely administer my server from my workstation?
 
You showed up just in time for the waffles! And this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic