Win a copy of Rust Web Development this week in the Other Languages forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Junilu Lacar
  • Rob Spoor
  • Paul Clapham
Saloon Keepers:
  • Tim Holloway
  • Tim Moores
  • Jesse Silverman
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Piet Souris
  • Frits Walraven

include taglibs problem

 
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have a commonTag.jspf that contains the following lines:-

<%@ taglib prefix="html"<br /> uri="http://jakarta.apache.org/taglibs/struts-html.tld" %>

<%@ taglib prefix="bean"<br /> uri="http://jakarta.apache.org/taglibs/struts-bean.tld" %>

<%@ taglib prefix="logic"<br /> uri="http://jakarta.apache.org/taglibs/struts-logic.tld" %>



In another jsp page, I include the above page using :-

<%@ include file="/common/commonTag.jspf"%>



It is working perfectly in JBOSS 4, but when I moved to RAD 6(Websphere
Studio 6), those taglib is not loaded. If I set those taglib in my
individual page, then it works. Why can't I put all taglib in one common page,
and then include from my individual page?

Guys, any idea?
 
cb poo
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have a commonTag.jspf that contains the following lines:-

<%@ taglib prefix="html"
uri="http://jakarta.apache.org/taglibs/struts-html.tld" %>

<%@ taglib prefix="bean"
uri="http://jakarta.apache.org/taglibs/struts-bean.tld" %>

<%@ taglib prefix="logic"
uri="http://jakarta.apache.org/taglibs/struts-logic.tld" %>



In another jsp page, I include the above page using :-

<%@ include file="/common/commonTag.jspf"%>



It is working perfectly in JBOSS 4, but when I moved to RAD 6(Websphere
Studio 6), those taglib is not loaded. If I set those taglib in my
individual page, then it works. Why can I put all taglib in one common page,
and then include from my individual page?

Guys, any idea?
 
reply
    Bookmark Topic Watch Topic
  • New Topic