• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Paul Clapham
  • Devaka Cooray
  • Bear Bibeault
Sheriffs:
  • Junilu Lacar
  • Knute Snortum
  • Liutauras Vilda
Saloon Keepers:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Piet Souris
Bartenders:
  • salvin francis
  • Carey Brown
  • Frits Walraven

failed to open MQ queue

 
Ranch Hand
Posts: 85
Eclipse IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am getting the following error when I start the server. This is the stack trace :




Can any1 pls help me with this.. I am new to the WebSphere world and I think maybe I have done some setting wrong.

Thanks,
Janhavi.
 
Ranch Hand
Posts: 57
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi
I have seen this recently. I think it may have to do with the set up of the queues from the MQ side rather than the jndi set up of the queues on Websphere. In my case our infrastructure people didn't set my MDB's reply queue as a remote queue. So the home/remote queues were deleted and redefined. However I'm not familar with the MQ commands to give you them but I'm sure they can be found on the web.
 
Ranch Hand
Posts: 82
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
the 2085 return code means unknown object. In order to 'create a queue', you need to have already defined the queue to your queue manager.
 
Janhavi Namshikar
Ranch Hand
Posts: 85
Eclipse IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The Queues are defined in the queue manager, and from the Administrative console I am doing the following :

Click on
Servers > Application Servers > servername > Server Components > JMS Server.
Then inside the Queue Names text area I enter the names of the queue that are defined in the Queue manager.
All the Q names are entered in different lines, no comma or semicolon is used as seperator. Am I doing something wrong here? or am I suppose to do some other settings for the Q?
I am using WSAD 5.1.0 and WebSphere MQ 6.0


Thanks,
Janhavi
 
david lightman
Ranch Hand
Posts: 82
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes, there is alot.
That is not where you want to be at all. Instead, go to resources, Websphere MQ JMS providers and add your QueueConnectionFactory and your QueueDestination (which is a pointer to the actual WMQ queue) then add a MessageListenerPort and attach the QCF and Qdest. Yuo should be set afterwards.
 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Janhavi,
It is also important to make sure that when ever you get JMS Exceptions, you obtain the linked Exception as well like
exception.getLinkedException()
This will give the specific error code, with which you will come to know the exact mq exception cause by looking up the mqrc details.

Thanks.
 
Arch enemy? I mean, I don't like you, but I don't think you qualify as "arch enemy". Here, try this tiny ad:
Two software engineers solve most of the world's problems in one K&R sized book
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
    Bookmark Topic Watch Topic
  • New Topic