Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

NoClassDefFound Error after adding war to ear project

 
Ranch Hand
Posts: 132
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello all,
I'm using wsad on Winxp. I have an enterprise projetct with a few ejb jars, and its starting and working correctly in wsad's server (5.1.2) test environment. After I add a war project to the ear one ejb-jar on startup starts complaining about a missing class, this class is in a module which is referenced in the manifest of ejb jar and the war.
I'm sure the answer is pretty simple but I right now I'm lost a bit.
Any help would be appreciated.
regards,
jeroen.
 
jeroen dijkmeijer
Ranch Hand
Posts: 132
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Answering my own question:
putting the classloader policy of the war to application did do the trick.
Not sure yet, how to set this up in the real server.
again regards.
    Bookmark Topic Watch Topic
  • New Topic