• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Updated Session Timeout not displayed in app

 
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
I wanted to update the session timeout value in WebSphere. I tried the following but still my test jsp which prints session.getMaxInactiveInterval() still shows the 1800 secs !

I tried the following -
a. Updated it using the admin console , which did not work as the web.xml has precedence over the Appserver's console settings.
b. Directly edited web.xml which also did not show any change.
c. Re deployed the web.xml using partial deploy in Websphere and still no change.

I cannot change the code and so want to avoid using setMaxTimeout.

I have started to believe that I am missing something fundamental .Any suggestions why this could be happening ?
 
Ranch Hand
Posts: 57
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Try a full redeploy.
 
Kunal Aher
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
As a last option I tried the partial update option in WAS instead of re-deploying the complete app and it works. Seems Websphere does not use the manually updated web.xml file.
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
i am using wepshpere 6.1.0.21

i set the session timeout using the console :

Application servers > server1 > Web container > Session management .
this sets the timeout for all applications on server1.
the session timeout here is 150 minutes.
i also set the sesion timeout on the application level to be 30minutes:
Enterprise Applications > Iag > Session management

but still the session of the application stays active for more than 30 minutes and more than 150 minutes.
 
It will give me the powers of the gods. Not bad for a tiny ad:
a bit of art, as a gift, that will fit in a stocking
https://gardener-gift.com
reply
    Bookmark Topic Watch Topic
  • New Topic