• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Sheriffs:
  • Ron McLeod
  • Devaka Cooray
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Frits Walraven
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • salvin francis
  • fred rosenberger

How to deploy a Tomcat.war file into WebSphere

 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have exported a Tomcat project into a .war file using ECLIPSE and use WebSphere Admin console to deploy that war file. However, it did not work like regular Webphere ear file that I exported from WSAD. Any suggestion of how to go about to deploy this Tomcat.war file will be greatly appreciated.

TT
 
author and cow tipper
Posts: 5000
1
Hibernate Spring Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You mention a tomcat war, but I'm guessing you're just implying that it is a standard war file which is deployable to any compliant Servlet engine, correct?

When you use the admin console to deploy, you'll have an option to deploy an ear, and you'll also have another radio button option to deploy a war, or a web module. Chose the web module option, and you'll be able to deploy the war.

You'll be asked for a context root. In tomcat, that's just the name of the war, minus the .war extension. So, provide a context root, and when you want to go to your landing page, the url will be something like:

http://localhost:9080/contextroot/index.jsp

Is there a particular error you're seeing? What happens when you try to deploy. Check the log files for any errors or exceptions.

Good luck!

-Cameron McKenzie
 
Tien Thai
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you very much for your reply, Cameron.
I did try to install the war file using WebSphere admin console and the installation was successful. Now, when I tried to SAVE (save link) to the master configuration, it took me back to the "Preparing for the application installation" window as opposed to be directing to other page (I forgot what that page was). I am able to start that new application but unable to view the page due to the following error:
Error 404: SRVE0190E: File not found: /nullnull

Please let me know shodul you have any suggestion.

Many thanks for your help.

TT
 
    Bookmark Topic Watch Topic
  • New Topic