• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Liutauras Vilda
  • Paul Clapham
  • paul wheaton
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Piet Souris
  • Mike London

Cannot configure Remote Debugging (JDev - OAS 10g)

Ranch Hand
Posts: 112
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I'm trying to make work remote debugging from JDeveloper 10.1.2 on Oracle AS 10g, but I'm stuck. I tried to do every step from JDeveloper help:

1. Create remote debugging process.
- Done (I hope)

2. In the <jdev_install>/lib directory, copy xmlparserv2.jar to <OC4J_HOME>/lib. In the <jdev_install>/jdev/lib directory, copy ojc.jar and jdev-rt.jar to <OC4J_HOME>/home/lib
- If ORACLE_HOME is C:\Oracle\oracleas, then where is OC4J_HOME ? c:\Oracle\oracleas\j2ee\home ? But it means to create another 'home' directory, right ? But I have already created one OC4J instance called FirstOC4J, where our applications are deployed and it is located in c:\Oracle\oracleas\j2ee\FirstOC4J. Now what ? Which one?

3. Edit global-web-application.xml, but it is both in c:\Oracle\oracleas\j2ee\FirstOC4J\config and in c:\Oracle\oracleas\j2ee\home\config directory. Which one ?

4.Start OC4J in debug mode from a command line
- Why from command line? And what about already started instance on AS? I always managed our FirstOC4J from Enterprise manager. I tried to put there the parameters from the command
java -ojvm -XXdebug,port4000,detached,quiet -jar oc4j.jar
but parameters inserted into OC4J Options or Java Options were rejected (OC4J wouldn't start). A little succes was running OC4J like this
But it worked only for the first time, now it reports
c:\Oracle\oracleas\j2ee\home>C:\jdev\jdk\bin\java -ojvm -XXdebug,port4000,detached,quiet -jar oc4j.jar
06/04/05 08:10:53 Error starting HTTP-Server: Address already in use: JVM_Bind
06/04/05 08:10:54 Oracle Application Server Containers for J2EE 10g ( initialized

Please , could somebody make some step-by-step instructions for begginners or at least comment some above points ? Thanks.
    Bookmark Topic Watch Topic
  • New Topic