Win a copy of Modern JavaScript for the Impatient this week in the Server-Side JavaScript and NodeJS forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

jsp & servlet url's require 2 hits to get a page??

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Config: Redhat 9, Apache 2.0.47, mod_jk 1.2.6, Tomcat 4.1.29
It takes a second request to get a jsp or servlet output to display in the browser: I type in the url (jsp or servlet) and hit Enter, the browser spins indefinitely. I then hit Enter a second time, and the page will immediately load. Restated: All servlets/jsp requests do load - but only on the second hit (request). However, any static html page (served through apache) loads immediately on the first hit.
If I hit the jsp/servlet through port 8080, it serves immediately. This doesn't seem to be a tomcat problem ( I suspect mod_jk), but since it does involve tomcat, I figured this forum would have the best shot at an answer.
The apache (access_log, error_log), mod_jk, and catalina logs do not show any errors. The catalina_log.*.txt shows sporadic "IOException Broken pipe" errors.
Any suggestions / advice would be appreciated. I have been writing java apps for a couple of years - some deployed to tomcat standalone, but this is my first adventure into tomcat connected to apache.
Thanks!!
Brent
[ February 11, 2004: Message edited by: Brent Parker ]
 
Brent Parker
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Fixed. Backed up to mod_jk 1.2.5 and problem was corrected.
 
I brought this back from the farm where they grow the tiny ads:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic