• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Junilu Lacar
  • Liutauras Vilda
Sheriffs:
  • Paul Clapham
  • Jeanne Boyarsky
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Piet Souris
  • Carey Brown
Bartenders:
  • Jesse Duncan
  • Frits Walraven
  • Mikalai Zaikin

Tomcat SSL

 
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
We're having problems getting Tomcat to work under SSL in WinXP and Win2K3. I have it configured and it serves up pages just fine. When we run load tests, however, it starts to fall apart.

When the load increases the client starts showing up ConnectException: connection refused messages.

Under http it works fine and handles an adequate load. I've set the maxThreads to 500 and am only running 400 concurrent client threads averaging out at around 20-30 rps at peak so I can't see that this is what is causing the problem.

I have tried various versions of tomcat (4.1.18, 4.1.30, 5.0.16, 5.0.24) and all of them have the same problem. I also tried it through IIS and Apache using connectors and the same thing happens.

I've tried playing with maxThreads, minThreads, maxKeepAlive, acceptCount and anything else I could find

We've used both JMeter, a custom built java load client and a custom built .NET load client (just in case it was something to do with the JSSE)

Any help or suggestions would be greatly appreciated.

Jesse
 
reply
    Bookmark Topic Watch Topic
  • New Topic