• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Junilu Lacar
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Rob Spoor
  • Bear Bibeault
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Piet Souris
  • Carey Brown
  • Stephan van Hulst
Bartenders:
  • Frits Walraven
  • fred rosenberger
  • salvin francis

Tomcat application connection problem with RMI

 
Ranch Hand
Posts: 59
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I have an application in Tomcat server, from which I am accesing a RMI server, which serves me some data, if I access through RMI default port it returns me the requested data, but if I access through some other port like 2005, it does not. Any one come across such situation, i request you to pass me some information on this.

Following are the set of things I have done to set port, correct me if I am doing wrong.

I am binding the object using following command,

Naming.bind("//12.22.123.232:2005/ServerObj", servObj);

Similarly I am looking up for the same port from client side like,

Naming.lookup("//12.22.123.232:2005/ServerObj");

I am also starting RMI registry to look for the same port only like,

LocateRegistry.createRegistry(2005);

Thanks in advance.

Regards,

Venkat
 
You showed up just in time for the waffles! And this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic