Win a copy of Spring Boot in Practice this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

Jsp not running

 
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
i extracted the tomcat using its bin file and placed into /usr/local folder.after successful setting of the java and Catalina home ..the tomcat is is successfully started.
i have also configured apache 2.something .its been placed in /usr/local/apache2.i have also configured mod connector.

when i run tomcat and point it to http://localhost:8080/ it shows HTTP 500 Status page and does not shows the default page of tomcat ...moreit does run any servletexamples and jsp examples.....
please help me ...urgent
 
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I would suggest you to see the tomcat server log.
You will have more information about what went wrong.
 
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hi as far as u problem is concern some possibility of cause
1. u must set Java PATH
2............. Java home path for ex.where is u Java home directory("JAVA_HOME");
this r enviroment variable

I hope u will get solution of u problem
if not send me u message
by
K&T
 
Ranch Hand
Posts: 295
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Talha,

Welcome to Javaranch.

If all the steps in installing Tomcat have been followed, Tomcat should come, when you call him. If he doesn't, then we have chances, the configuration being wrong.

Any ways, check all these steps and try starting again.


1. Set the environment variable CATALINA_HOME to your Tomcat folder

say c:\Tomcat(Better to delete all the 4.1.stuff....to avoid chaos
due to spaces)

2. Set JAVA_HOME variable to the JDK folder.

Say c:\jdk1.3 or something

3. Set CLASSPATH variable to %CATALINA_HOME%\common\lib\servlet.jar;

4. Set Path variable to ;%JAVA_HOME%\bin;%CATALINA_HOME%\bin;



Hope this helps you. Have a nice time.

Cheers,
Ram.
[ September 01, 2005: Message edited by: Ramaswamy Srinivasan ]
 
Sheriff
Posts: 13411
Firefox Browser VI Editor Redhat
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator


3. Set CLASSPATH variable to %CATALINA_HOME%\common\lib\servlet.jar;

4. Set Path variable to ;%JAVA_HOME%\bin;%CATALINA_HOME%\bin;



The classpath variable doens't need to be set in order to run Tomcat.
Tomcat uses custom classloaders and will ignore your classpath setting.
(You will, however need to set that if you want to compile your own servlets from the command line.)

CATALINA_HOME\bin doesn't need to be on your PATH environment variable.
 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic